OL97: Schedule+ 1.0 Users May Not See Outlook Free/Busy Times (168687)



The information in this article applies to:

  • Microsoft Outlook 97
  • Microsoft Schedule+ 1.0

This article was previously published under Q168687

SYMPTOMS

You are using Schedule+ version 1.0 and trying to view the free/busy status of another person who has migrated from Schedule+ 1.0 to the Microsoft Outlook 97 Calendar. The free/busy information is not available for viewing. An indication that free/busy status cannot be read is the checkmark to the left of the user name in the Attendees is a lighter shade of gray than the check box by your name.

CAUSE

Schedule+ 1.0 has a feature that allows you to set permissions for viewing of free/busy status. When a Schedule+ 1.0 user queries for free/busy status, Schedule+ first checks a permission table to see if permission to read the free/busy information has been denied. If permission has been denied then no free/busy status is available in the planner view.

The permission table is stored separately from the calendar file. When you upgrade from Schedule+ 1.0 to Outlook, the free/busy permissions table is not changed or migrated in any way. Additionally, since Outlook (and Schedule+ 7.x) do not allow for permission settings for free/busy viewing, there is no option in Outlook to change the permission settings that were applied in Schedule + 1.0. If a Schedule+ user did not have permission to view your free/busy status in Schedule+ 1.0, they will not have permission to view it after you upgrade to Outlook.

Setting permissions to not allow reading of free/busy status is rare. The permission exist by default, and in practice is rarely turned off.

RESOLUTION

After you upgrade to Outlook, since there is no direct option to adjust the permission table, you can use either of the methods below to change the permissions that were set using Schedule+ 1.0:

Method 1

On the Options menu, click, Set Access Privileges and make the permissions changes. This can be done without adversely affecting any calendar data that has been migrated to Outlook.

Method 2

Start Outlook one time only with the, /cleanschedplus command line switch. This will delete all Schedule+ data (free/busy, permissions, and .CAL file) from the server and allow the free/busy information from the Outlook Calendar to be used and viewed by all Schedule+ 1.0 users. To start Outlook with the /cleanschedplus command line switch, use the following steps:
  1. In Windows 95 or Windows NT Workstation 4.0, use the right mouse button to click the Microsoft Outlook icon, click Properties, and then click the Shortcut tab.

    In Windows NT Workstation 3.51, click the Microsoft Outlook icon, and then click Properties on the File menu.
  2. In the Target box or the Command Line box, type the path to the Microsoft Outlook program file, type a space after the path, and then type /cleanschedplus.

    NOTE: If any path listed in the Target box (or Command Line box) contains spaces, such as C:\Program Files, you must enclose the path in quotation marks and use the correct case for each character in the path. The /cleanschedplus command line switch must be typed outside the quotation mark.

MORE INFORMATION

This issue only occurs when the post office being used is a Shared File System (SFS) post office (Microsoft Mail or Workgroup Post Office). There are also other factors which affect your ability to view free/busy status. For example, Outlook users can choose not to publish free/busy times, so other users cannot see free/busy status.

Modification Type:MajorLast Reviewed:10/27/2000
Keywords:kbinterop KB168687