SMS: Despooler Service Processes SNI Files Slowly (168130)
The information in this article applies to:
- Microsoft Systems Management Server 1.2
This article was previously published under Q168130 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
After Systems Management Server jobs are canceled, it may appear that
subsequent jobs remain in a Pending state. The Systems Management Server
Despoolr.log file may display the following:
Despooler failed to execute the instruction, error code = 38a
CAUSE
Canceling a Systems Management Server job may corrupt the .sni file. This
causes the Despooler service to process very slowly through each corrupt
file, and display the message shown in the SYMPTOMS section of this article. These .sni files are job status MIFs returning from the client, and are processed before .ins files. It appears that Despooler is not getting to the Pending jobs.
Additionally, deleting an Active job or deleting a job before it is completely canceled can also cause the error to occur.
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Size File name Platform
-------------------------------------------------
2/24/99 1:35pm 254,400 Smsinst.dll X86
2/24/99 1:34pm 481,040 Smsinst.dll ALPHA
NOTE: Due to file dependencies, the most recent hotfix or feature that contains the above files may also contain additional files. WORKAROUND
To work around this problem, examine the Sms\Site.srv\Despoolr.box\Receive directory and move all .sni files that are unrelated to current active jobs to a temporary subdirectory.
The following are some good practices to implement:
- If you cancel your jobs, do not delete them until they have been canceled for 48 hours.
- If you are canceling jobs, do not cancel more than one at a time.
- Do not delete Active jobs.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server version 1.2.
Modification Type: | Minor | Last Reviewed: | 10/7/2005 |
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Keywords: | kbHotfixServer kbQFE kbBug kbDespooler kbfix kbQFE KB168130 |
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