Attempt to Insert Column or Row Results in Error Message (168002)



The information in this article applies to:

  • Microsoft Pocket Excel 1.0

This article was previously published under Q168002

SYMPTOMS

When you attempt to insert a column or row in Pocket Excel, you may receive one or more of the following error messages:
  • Cannot shift nonblank cells off the worksheet.
  • There is not enough memory. Close other applications or documents and try the operation again.
Or, the screen flashes as if new columns or rows are being added to the spreadsheet.

CAUSE

This behavior occurs when any of the following conditions exists:
  • There is data in column IV or row 16384. You cannot add another row or column because you have reached the column or row limit in Pocket Excel.

    NOTE: Column IV and row 16384 are the last available column and row in Pocket Excel.
  • There is not enough available program memory to complete the insert operation.

RESOLUTION

To resolve this problem, use the appropriate method:

Method 1

Remove the data in column IV or row 16384. To do so, follow these steps:
  1. Tap the column or row heading to select the column or row.
  2. On the Edit menu, tap Clear, tap All, and then tap OK.
NOTE: This deletes any data in these cells.

Method 2

Increase available program memory. To do so, follow these steps:
  1. Tap the Start button, tap Settings, and then double-tap System.
  2. Tap the Memory tab, move the slider to the left, and then tap OK.
NOTE: Do not move the slider all the way to the left, as this may result in a lack of available storage memory.

Method 3

Insert a smaller range of columns or rows at a time.

Modification Type:MajorLast Reviewed:11/27/1999
Keywords:kberrmsg KB168002