XL97: Objects Are Printed Incorrectly on HP DeskJet 1600c (167725)



The information in this article applies to:

  • Microsoft Excel 97 for Windows

This article was previously published under Q167725

SYMPTOMS

In Microsoft Excel 97, when you print a worksheet or chart that contains drawing objects or AutoShapes, the following problems may occur:
  • Objects that are empty are printed with a black fill. -or-

  • Objects that contain a gradient fill are printed with a rainbow fill. -or-

  • Shadows are printed using the wrong color (green instead of black).
In addition, an "Out of memory" message may appear on the printer display panel when you print a very large or complex worksheet or chart.

CAUSE

These problems may occur if the following conditions are true:
  • You are printing to a Hewlett-Packard DeskJet 1600c ColorSmart printer. -and-

  • The version number of the printer driver is earlier than 4.2.

RESOLUTION

To resolve these problems, download and install a newer printer driver from the Hewlett-Packard Web site.

To obtain a new driver for your printer, use your Web browser to go to the following address: Then, click the Download Page link, scroll down to the "Download Information" section, and click the link for the driver you want to download (U.S. or Europe). If you are prompted to open or save the file, save it in a folder on your hard disk. Then, run the file. After the file is decompressed, run the Setup.exe file in that folder to install the new printer driver.

NOTE: Microsoft does not support the downloading and installation of printer drivers from the Hewlett-Packard Web site. If you require assistance downloading and installing drivers, contact Hewlett-Packard technical support. The Hewlett-Packard Web address is correct as of April 23, 1997. You can also view the main Hewlett-Packard Web site at the following address:

The third-party contact information included in this article is provided to help you find the technical support you need. This contact information is subject to change without notice. Microsoft in no way guarantees the accuracy of this third-party contact information.

STATUS

This problem was corrected in version 4.2 of the Hewlett-Packard DeskJet 1600c ColorSmart printer driver.

MORE INFORMATION

Note that if you download and install a newer printer driver for the Hewlett-Packard DeskJet 1600c ColorSmart printer, you may still receive an "Out of memory" message when you print very large or complex documents. If this behavior occurs, try upgrading the memory in your printer.

Hewlett-Packard DeskJet 1600c printers may contain from 4 MB to 100 MB of random access memory. When you install more memory in the printer, the message is less likely to appear.

Modification Type:MajorLast Reviewed:9/7/2001
Keywords:kb3rdparty kbprb kbprint KB167725