PRB: Unable to Open User Login File (167262)



The information in this article applies to:

  • Microsoft Visual SourceSafe, 16-bit, for Windows 4.0
  • Microsoft Visual SourceSafe, 32-bit, for Windows 4.0
  • Microsoft Visual SourceSafe, 16-bit, for Windows 4.0a
  • Microsoft Visual SourceSafe, 32-bit, for Windows 4.0a
  • Microsoft Visual SourceSafe for Windows 4.0
  • Microsoft Visual SourceSafe for Windows 4.0a
  • Microsoft Visual SourceSafe for Windows 5.0

This article was previously published under Q167262

SYMPTOMS

In Visual SourceSafe 5.0, the user receives the message:
Unable to create user login file <LogFile Name>
A similar message occurs in Visual SourceSafe 4.0:
Access to the file Rights.Dat denied.

CAUSE

These errors occur because the user does not have Write access to the Visual SourceSafe database.

RESOLUTION

The solution to these problems is to grant the user full rights to the Visual SourceSafe directory and all subdirectories.

All Visual SourceSafe users must have the ability to read, write, create and erase files in the Visual SourceSafe directory and all subdirectories.

For additional information, please see the following articles in the Microsoft Knowledge Base:

131022 Required Network Rights for the SourceSafe Directories

149586 INFO: VSS on Windows NT Workstation w/ FAT Partition

STATUS

This behavior is by design.

MORE INFORMATION

In addition, when you use Windows NT as the server for the Visual SourceSafe database you must make sure that the Share and Directory permissions are the same. In Windows NT, you grant a user access by giving them permission to access a share. You can also control rights to individual directories. If the user has full rights to the directory and read-only rights to the share, he/she will get the error.

Modification Type:MajorLast Reviewed:5/4/2001
Keywords:kbprb kbSSExplorer kbui KB167262