Add Printer Wizard May Hang After Adding a Port (167046)



The information in this article applies to:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q167046

SYMPTOMS

After you click Next, the Add Printer Wizard does not respond. The problem occurs with any user, even Administrator, but works properly after the server is restarted or the Spooler service is stopped and then restarted.

CAUSE

A user in the Print Operator group or Power User group has attempted to create a printer using an LPR port.

Printer Operators and Power Users can create printers but do not have sufficient access to the registry to create new printer ports.

For additional information, please see the following article in the Microsoft Knowledge Base:

ARTICLE-ID: 140084
TITLE : Permissions Error Creating an LPR Printer

RESOLUTION

Stop and restart the Spooler service or, shutdown and restart the server.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows NT Server version 4.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:9/7/2001
Keywords:kbbug kbprint KB167046