No Crashdump and Compaq Systems with Smart-2/P (PCI) Controller (166874)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q166874 SYMPTOMS
On Compaq systems running a Smart-2/P (PCI) controller as the boot device,
a blue screen error may not generate a crashdump file. This occurs even
though the crashdump requirements are met.
CAUSE
Compaq 1500 and 5000 systems frequently run a Smart-2/P (PCI) controller to
control the disk drive containing the Windows NT boot partition. A special
Windows NT function call contained in the PCI Find Adapter routine returns
an error condition when called at crashtime. As a result of this, the PCI
Smart-2/P adapter is not found to be present at crashtime and no crashdump
file is generated.
RESOLUTION
A new version of Cpqarray.sys is available to correct this problem. Compaq
has included this hotfix in their Softpaq - SP2746.exe. They have also
indicated that it will be incorporated in the upcoming SSD 1.21 release.
STATUS
Microsoft has confirmed this to be a problem in Windows NT version 4.0.
This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service
Pack. For information on obtaining the service pack, query on the following word
in the Microsoft Knowledge Base (without the spaces):
Modification Type: | Major | Last Reviewed: | 8/9/2001 |
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Keywords: | kb3rdparty kbbug KB166874 |
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