"Missing Mapi32.dll:239" Error Message Occurs When You Start Outlook (166757)



The information in this article applies to:

  • Microsoft Outlook 97

This article was previously published under Q166757

SYMPTOMS

When you start Microsoft Outlook 97, you may receive the following error message:
Outllib.dll is linked to a missing export Mapi32.dll:239

CAUSE

Outlook Setup did not properly update the Mapi32.dll file, or an incorrect version of the Mapi32.dll file is located in a directory other than your default Windows\System directory.

RESOLUTION

To resolve this issue, search for and rename extra Mapi32.dll files:
  1. Quit all running programs.
  2. Click Start on the Windows Taskbar.
  3. Point to Find, and then click Files or Folders to search for Mapi32.dll files.
  4. Rename any Mapi32.dll files that are not located in the default Windows\System directory. To do so:
    1. Right-click the file name.
    2. Click Rename on the shortcut menu.
  5. Close the Find dialog box, and then restart Outlook.
If the problem persists, copy a new Mapi32.dll file from your Outlook Setup medium to your default Windows\System directory:
  1. Quit all running programs.
  2. Click Start on the Windows Taskbar, point to Find, click Files or Folders to search for Mapi32.dll, and then rename the file.
  3. Change the Look in box on the Find dialog box to point to your Outlook Setup medium, and then search for the Mapi32.dll file.
  4. Copy the Mapi32.dll file to one of the following directories on your computer:
    • Windows\System (if you are running Windows 95)

      -or-
    • Winnt\System32 (if you are running Windows NT)
  5. Right-click the Mapi32.dll file on your computer and click Properties.
  6. Under Attributes, click to select Archive.

Modification Type:MajorLast Reviewed:8/29/2001
Keywords:kberrmsg kbprb KB166757