XCON: Delivery Reports Contain only Distinguished Names in a Non-replicated Exchange Environment (166619)



The information in this article applies to:

  • Microsoft Exchange Server 4.0
  • Microsoft Exchange Server 5.0

This article was previously published under Q166619

SYMPTOMS

Delivery Reports (DRs) received from another Microsoft Exchange Server may only contain the Distinguished Name (DN) of the original recipient in the envelope. This behavior does not affect normal users, but if the DR is received by an EDK based agent or gateway, it is no longer possible to relate the DR to the original message. The DN used in the delivery report is not usable, since the receiving Microsoft Exchange Server doesn't have any information about the other Microsoft Exchange Organization.

CAUSE

This behavior can occur when the DR is generated by another Microsoft Exchange Organization that is connected by a 88 X400 Connector and Directory Replication is not configured between the two Organizations. As a result, the X.400 O/R address is stripped from the DR and when the MTA receives the DR, only the DN is left.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server, version 4.0. This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 4.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0. This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 5.0. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

WORKAROUND

Use a 1984 X400 connection instead of a 1988 X400 connection.

MORE INFORMATION

The hotfix is only needed if you are working with two Microsoft Exchange Servers that do not have Directory Replication configured between them or that are in different Organizations. Without the fix, a DR may contain only a DN that references the user to whom a message was delivered successfully.

The fix changes the handling of invalid DNs, so that the DR always contains a valid, usable address. This address can be a O/R address or a DN.

To install the fix, follow these steps:

  1. Stop all Microsoft Exchange services.
  2. Backup the following files from the <path>\exchsrvr\bin directory by renaming or copying them to another location:

    ADDRESS.DLL, EMSMTA.EXE, MTACHECK.EXE, MMIEXT.DLL, SAALOG.DLL, EMS_RID.DLL, P2.XV2, X400OMV1.DLL

  3. Backup the following files from the <path>\exchsrvr\mtadata directory by renaming or copying them to another location:

    P2.XV2, INFOTLOG.CFG, INFODLOG.CFG, P3.TPL, DBSERVER.SCH, DCPRODS.CAT

  4. Backup the following file from the <path>\exchsrvr\connect\msexcimc\bin directory by renaming or copying it to another location:

    ADDRESS.DLL

  5. Backup the following file from the <path>\exchsrvr\connect\msmcon\bin directory by renaming or copying it to another location:

    ADDRESS.DLL (if existing)

  6. Backup the following file from the <path>\exchsrvr\res directory by renaming or copying it to another location:

    MTALOG.DLL

  7. Backup the following file from the <path>\<winntroot>\system32 directory by renaming or copying it to another location:

    MAPI32.DLL

  8. Replace all the above files with the ones provided with the hotfix.
  9. Restart all services stopped in step 1.
Please note that it might be necessary to reboot the computer in order for the changes introduced with MAPI32.DLL to take effect.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbbug kbfix KB166619