XCON: MTA: Messages not Being Delivered Over the First Association (166594)



The information in this article applies to:

  • Microsoft Exchange Server 4.0
  • Microsoft Exchange Server 5.0

This article was previously published under Q166594

SYMPTOMS

The Microsoft Exchange Message Transfer Agent (MTA) has a backlog of messages (up to the default threshold) waiting to be delivered. The MTA makes an association with another LAN-MTA (RPC connection), but does not deliver mail over this connection.

CAUSE

The MTAs on both sides of the connection detect that the opposite MTA has the Turn to send messages. Because of this confusion, neither side sends messages.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 4.0. This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 4.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0. This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 5.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

MORE INFORMATION

The initiating MTA has passed the Turn to the receiving MTA, but the receiving MTA does not get it because the association is lost (for whatever reason). When the initiating MTA recovers the association and asks for the Turn back, the receiving MTA ignores this request because it does not believe it has the Turn. Therefore, no one has the Turn and no messages will be sent.

After the message threshold has been reached (default value is 50), the MTAs will make a new association and begin delivering messages.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kbfix KB166594