Err Msg: Shdocvw.dll Could Not Be Found in the Specified Path (166346)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows NT 4.0

This article was previously published under Q166346

SYMPTOMS

When you attempt to start any of the versions of Internet Explorer listed at the beginning of this article after upgrading from a previous version of Internet Explorer, the following error message may be displayed:
Shdocvw.dll could not be found in specified path.

CAUSE

This problem is known to occur when the following conditions are true:

  • Your computer is configured as a dual-boot system (that is, it is configured to run both Windows 95 and Windows NT).

    -and-
  • You installed your previous version of Internet Explorer in both Windows 95 and Windows NT.
If you upgrade one installation of Internet Explorer, but not the other, the error message is displayed when you attempt to start the installation of Internet Explorer that you did not upgrade.

Note that this problem occurs only when your previous versions of Internet Explorer for Windows 95 and Internet Explorer for Windows NT were installed in the same folder.

When you install Internet Explorer, both the Internet Explorer for Windows 95 and Internet Explorer for Windows NT files are updated. However, only the registry and files associated with the operating system that is currently running are updated. Because the registry and files associated with the other operating system are not updated, Internet Explorer does not run properly when you start that operating system.

RESOLUTION

To resolve this problem, upgrade both installations of Internet Explorer.

Modification Type:MajorLast Reviewed:12/16/2003
Keywords:kbenv kberrmsg KB166346