WD97: Hang When Sending E-mail Twice In Rapid Succession (166278)



The information in this article applies to:

  • Microsoft Word 97 for Windows
  • Microsoft Outlook 97
  • Microsoft Exchange 4.0

This article was previously published under Q166278

SYMPTOMS

Microsoft Word 97, Microsoft Outlook 97, or Microsoft Exchange will appear to stop responding (hang) when you send email from Word 97. This problem occurs when either of the following is true:

  • You click the "Send resume to someone" option in the Office Assistant when the Resume Wizard is finished, and then immediately click the "Send resume to someone" option again before the first message is sent. -or-

  • You are running a Visual Basic for Applications macro that calls the SendMail command multiple times in quick succession, as in the following example:

    ActiveDocument.SendMail ActiveDocument.SendMail

CAUSE

The programs listed above stop responding when you are using Word as your email editor and the ActiveDocument.SendMail command is called two or more times in quick succession.

WORKAROUND

While the Microsoft Exchange or Microsoft Outlook message indicating that an action could not be completed is displayed on the screen, do the following to recover from this problem:

  1. Open the Close Program dialog box by pressing CTRL+ALT+DEL.
  2. In the Task list, select Microsoft Outlook or Microsoft Exchange, and then click End Task.
  3. If you receive a message asking if you want to wait or end the task, click End Task.
  4. Click OK in the Microsoft Exchange or Microsoft Outlook message box.
  5. Choose one of the following:

    • Click OK if you are using the Resume Wizard and you received the following error message:
      The Wizard could not send the document. Word couldn't
      send mail because of 'MAPI' failure: "Unspecified error."
      -or-

    • Click End if you are using a Visual Basic for Applications macro and you received the following error:
      Word couldn't send mail because of 'MAPI' failure: "Unspecified error."
Word should now respond. Save and close any open documents, exit Word and any other open programs, restart Windows, and then restart your programs.

To prevent this problem turn off WordMail. For more information about how to do this, please see the following articles in the Microsoft Knowledge Base:

159476 How to Enable, Disable Microsoft Word as the E-Mail Editor

135295 How to Enable, Disable Word as Your E-mail Editor in Exchange

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2006
Keywords:kbinterop kbprogramming kbtemplate KB166278