Error Message: "Assert Failed: Process: Iexplore.exe" (166116)
The information in this article applies to:
- Microsoft Internet Explorer 1.0 for Windows 95
- Microsoft Internet Explorer 2.0 for Windows 95
- Microsoft Internet Explorer 3.0 for Windows 95
- Microsoft Internet Explorer 3.01 for Windows 95
- Microsoft Internet Explorer 3.02 for Windows 95
- Microsoft Internet Explorer 4.0 for Windows 95
- Microsoft Internet Explorer 4.01 for Windows 95
- Microsoft Internet Explorer 5.0 for Windows 95
- Microsoft Internet Explorer 5.01 for Windows 95
- Microsoft Internet Explorer 5.5 for Windows 95
- Microsoft Internet Explorer 3.x for Windows 95
- Microsoft Internet Explorer 4.x for Windows 95
- Microsoft Internet Explorer 2.0 for Windows NT 4.0
- Microsoft Internet Explorer 3.0 for Windows NT 4.0
- Microsoft Internet Explorer 3.01 for Windows NT 4.0
- Microsoft Internet Explorer 3.02 for Windows NT 4.0
- Microsoft Internet Explorer 4.0 for Windows NT 4.0
- Microsoft Internet Explorer 4.01 for Windows NT 4.0
- Microsoft Internet Explorer 5.0 for Windows NT 4.0
- Microsoft Internet Explorer 5.01 for Windows NT 4.0
- Microsoft Internet Explorer 5.5 for Windows NT 4.0
This article was previously published under Q166116 SYMPTOMS
When Internet Explorer opens a Hypertext Markup Language (HTML) page that
includes an OBJECT tag, you may receive the following error message:
Assert Failed: Process: Iexplore.exe PID:xx TID:xx
File:<pathname\filename>(xxx)
0 && "Unexpected call to client site."
CAUSE
The OBJECT tag in the HTML file is referring to an ill-behaved OLE or
ActiveX control.
RESOLUTION
To resolve this problem, contact the individual who wrote the ActiveX
control (the author) and tell that author about the error message that you
are receiving. The author of the control will need to redesign it so that
the error message does not occur.
MORE INFORMATION
Assert errors usually occur when an object attempts to call an interface
method when it is not allowed or expected to.
Modification Type: | Major | Last Reviewed: | 12/16/2003 |
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Keywords: | kberrmsg KB166116 |
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