OFF: "Out of Memory" Messages When Running Microsoft Office (165985)
The information in this article applies to:
- Microsoft Office for Windows 95
- Microsoft Office for Windows 95 7.0a
- Microsoft Office 97 for Windows
This article was previously published under Q165985 SYMPTOMS
When you run a Microsoft Office program, you may receive one or more of the
following error messages:
Out of memory.
Not enough memory to display completely.
Your file could not be printed due to an error on <printer name>.
This program has performed an illegal operation and will be shut down.
If the problem persists, contact the program vendor.
If you click Details, you receive an error message that is similar to
the following:
<program> caused an invalid page fault in module MSO97.DLL at
<address>.
In addition, the amount of available random access memory in your System
and graphics device interface (GDI) memory heaps may drop to a very low
level (10 percent or less).
These problems may occur especially when you use Microsoft Word as your
e-mail editor.
CAUSE
These problems may occur if the following conditions are true:
- A printer driver for any of the following printers is installed on your
computer:
HP DeskJet 660C
HP DeskJet 670c
HP DeskJet 672c
HP DeskJet 680C
HP DeskJet 690C
HP DeskJet 692C
HP DeskJet 694C
HP DeskJet 772C
HP DeskJet 820
HP DeskJet 820C
HP DeskJet 820CSE
HP DeskJet 870Cse
HP DeskJet 870Cxi
HP DeskJet 890c
HP LaserJet 6P
HP LaserJet 4000
Lexmark 1250
-and-
- One of these printers is the default printer.
WORKAROUND
You may be able to reduce the effects of this problem by doing one of the
following:
- It is possible that using an earlier version of the printer driver will
correct the problem; however, this has not been confirmed by Microsoft.
- It is also possible that the latest version of the printer driver will
correct the problem. The latest versions of the printer drivers can be
downloaded from the following Hewlett-Packard Internet web site:
The third-party contact information included in this article is
provided to help you find the technical support you need. This contact
information is subject to change without notice. Microsoft in no way
guarantees the accuracy of this third-party contact information.
- Before you start the Microsoft Office program or any other program in
which the problem may occur, set the default printer to a printer that
is different from the printers listed in this article.
- If you must use one of the printers listed in this article, do not print
or view the document in print preview unless it is necessary. Every time
you use the printer driver more memory is lost in your System and
graphics device interface (GDI) memory heaps.
- Save your work often.
- If you start to encounter problems that are related to memory, save your
work, quit all open programs, and then restart your computer.
MORE INFORMATION
The printers listed in this article do not contain their own memory;
instead, the printer drivers are designed to use the computer memory when
rendering and processing print jobs.
The third-party products discussed here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.
Modification Type: | Minor | Last Reviewed: | 8/17/2005 |
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Keywords: | kb3rdparty kberrmsg kbprb kbprint KB165985 |
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