PRB: Error "File c:\.dbc does not exist" in Visual FoxPro (165306)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 3.0
- Microsoft Visual FoxPro for Windows 3.0b
- Microsoft Visual FoxPro for Windows 5.0
- Microsoft Visual FoxPro for Windows 5.0a
- Microsoft Visual FoxPro for Windows 6.0
- Microsoft Visual FoxPro for Macintosh 3.0b
This article was previously published under Q165306 SYMPTOMS
The error "File c:\.dbc does not exist" occurs when an exclamation point
(!) is used as the first character in the name of the directory that a
table is located in. On the Macintosh the error is as follows:
File 'Hardrivename:.dbc' does not exist
If the exclamation point is at the end of the folder name the error is as
follows:
File c:\<foldername>.dbc does not exist
CAUSE
An exclamation point is used in the folder or directory containing the
table. When opening a table the name of the database may be used. The
exclamation point is used as the separator between the database name and
the table name.
USE C:\Vfp\Samples\Data\Testdata!Customer
FoxPro is looking for a DBC with the same name as the folder or directory.
RESOLUTION
Do not use exclamation points in folder or directory names.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 5/12/2003 |
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Keywords: | kbprb kbprogramming kbusage KB165306 |
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