DDE Client Experiences Intermittent DDE Disconnects (165245)



The information in this article applies to:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q165245

SYMPTOMS

A DDE client application may experience intermittent DDE disconnect problems.

CAUSE

XTYP_DISCONNECT message is sent by DDEML to the client application under the following scenario:
  1. Server is generating frequent calls to DdePostAdvise() on a single data item.
  2. Client is making frequent requests to advise/unadvise on the same item.
The client transactions must be of type
   XTYP_ADVSTART | XTYPF_ADVREQ and XTYP_ADVSTOP.
   (Hot links of type XTYP_ADVSTART do not exhibit this problem.)
				

Under these circumstances, when a data packet is generated by the server after DDEML is notified by the client of a request to unadvise but prior to the generation of the ACK for this unadvise, DDEML sends a message of type XTYP_DISCONNECT to the client.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows NT version 4.0. This problem was corrected in the latest Microsoft Windows NT 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:8/10/2001
Keywords:kbbug kbnetwork KB165245