Corrupt Files Error After You Apply Service Pack 2 (165002)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0 SP2
- Microsoft Windows NT Server 4.0 SP2
This article was previously published under Q165002 SYMPTOMS
After you apply Service Pack 2 for Windows NT 4.0 over the network and
restart your computer, you may receive error messages stating that some
files (for example Ntfs.sys or Advapi32.dll) are corrupt.
CAUSE
This problem occurs because the Service Pack 2 binary files were packaged
using authentication for web distribution. You only experience this problem
when you expand a previous version of Service Pack 2 and then copy the
files from one computer with an NTFS partition to another computer over the
network (and only when the two systems negotiate raw write mode between
them.)
The specific files affected by this problem are:
Ntfs.sys
Advapi32.dll
Winhlp32.exe
Halapic.dll
This does not occur with the CD-ROM version of Service Pack 2.
RESOLUTION
The Service Pack 2 binary files were repackaged to resolve this problem.
Please download the Service Pack 2 files again.
IMPORTANT: The files did not change, they were only repackaged without
authentication.
NOTE: If your system no longer starts due to Ntoskrnl.exe or other critical
system files being corrupt, you must replace these files manually. This may
require you to install another copy of Windows NT in different folder so
that you can access the original installation, especially on an NTFS
partition.
Modification Type: | Major | Last Reviewed: | 5/13/2003 |
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Keywords: | kbbug kbfile kbsetup KB165002 |
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