Remote Procedure Call (RPC) Service Access Violation (164758)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q164758 SYMPTOMS
The remote procedure call (RPC) service fails with an access violation.
Typically, this produces a failure report in the Drwtsn32.log file that
looks similar to the following:
Application exception occurred:
App: exe\rpcss.dbg (pid=129)
When: 03/04/1997 @ 11:17:7.316
Exception number: c0000005 (access violation)
CAUSE
A corrupt RPC packet is being sent to the remote procedure call (RPC)
service. The code that unmarshalls the data (unpacks it for execution)
fails under certain conditions of packet corruption.
RESOLUTION
The only workaround to the problem is to determine the cause of the RPC
packet corruption from the client. This has been historically traced back
to hardware problems caused by a failure to copy the bytes of the packet
correctly by a router, bridge, or network card. In one instance, a network
card was using bus mastering I/O and this appeared to be causing the frame
to be transmitted improperly. Disabling bus mastering on the client network
card solved this problem.
STATUS
Microsoft has confirmed this to be a problem in Windows NT version 4.0.
This problem was corrected in the latest Microsoft Windows NT 4.0 U.S.
Service
Pack. For information on obtaining the service pack, query on the following
word
in the Microsoft Knowledge Base (without the spaces):
Modification Type: | Major | Last Reviewed: | 8/8/2001 |
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Keywords: | kbbug kbHardware kbnetwork kbRPC KB164758 |
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