Winsock Client May Fail to Connect to Proxy Server if TCP/IP Disabled or Bound to a Modem (164675)



The information in this article applies to:

  • Microsoft Proxy Server 1.0
  • Microsoft Proxy Server 2.0

This article was previously published under Q164675

SYMPTOMS

When you use the Microsoft Winsock Proxy client with a client that uses both TCP/IP and IPX/SPX, the client may fail to connect to the Proxy Server if TCP/IP is disabled or bound to a modem.

CAUSE

The Winsock Proxy client always tries to use TCP/IP by default. If TCP/IP is not configured so that a TCP/IP connection can be made with the Proxy Server, the Winsock Proxy client will fail.

WORKAROUND

You can force Proxy Server to use IPX by using one of the following methods:

  • Remove the TCP/IP protocol from the client computer.
  • Edit the Mspclnt.ini file on the Proxy Server located in the \Msp\Clients directory, by default, and remove the following section from Mspclnt.ini:
          [Servers Ip Addresses]
          Name=[ProxyServerName]
    						
    After you edit and save the file, open the Control Panel on the Winsock Proxy client computer. Open WSP Client and select Update Now.

MORE INFORMATION

For additional information regarding configuring Proxy Server with IPX clients, please see the following article in the Microsoft Knowledge Base:

165341 Configuring Proxy Server with the IPX Protocol


Modification Type:MajorLast Reviewed:10/7/1999
Keywords:kbprb KB164675