SNA Windows 95 Fails Logon If Password Change Required (164639)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q164639

SYMPTOMS

If the Windows NT Server 4.0 user account is configured to require the user to change the password at the next logon attempt, and the SNA Server Windows 95 client is configured to use a non-named pipe transport, the SNA Server Windows 95 client logon will report a logon failure.

CAUSE

The Windows NT logon security mechanism used by the SNA Server Windows 95 client does not support the change password feature.

RESOLUTION

An update to Windows NT Server 4.0 (included in Service Pack 3), adds support for Change Password notification. In addition to this change, SNA Server 3.0 and the Windows 95 SNA 3.0 client have been modified to use this new notification feature.

The following updated SNA Server modules are available:

SNA Server

     \<snaroot>\System\Snadmod.dll   \<snaroot>\System\Snaevent.dll
				

Windows 95 SNA Client

     \<windir>\System\Snakrnl.dll   \<windir>\System\Snabase.exe
				
NOTE: Windows NT Server 3.51 and SNA Server 2.11 do not support change password notification needed by the SNA Server Windows 95 client. The updated version of Windows NT Server 4.0 must be used with SNA Server 3.0 (on the server and Windows 95 client) in order to support this feature.

STATUS

Microsoft has confirmed this to be a problem in SNA Server version 3.0. This problem was corrected in the latest Microsoft SNA Server 3.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:5/22/2003
Keywords:kbbug kbfix kbnetwork KB164639