FIX: VSS Log Files Not Deleted Correctly on NetWare (164585)
The information in this article applies to:
- Microsoft Visual SourceSafe, 16-bit, for Windows 4.0
- Microsoft Visual SourceSafe, 16-bit, for Windows 4.0a
- Microsoft Visual SourceSafe, 32-bit, for Windows 4.0
- Microsoft Visual SourceSafe, 32-bit, for Windows 4.0a
This article was previously published under Q164585 SYMPTOMS
If your SourceSafe database contains log files with no matching data
files, the following error message may appear when you run analyze:
The data file for <real file name > (<physical file name>) was not
found
CAUSE
When you delete and permanently destroy files in a SourceSafe database
that reside on a Novell NetWare Server, the SourceSafe log file is not
deleted.
This happens on Windows95 machines using the Microsoft client for NetWare
Networks.
RESOLUTION
This problem has been corrected in Visual SourceSafe version 5.0.
There are two ways to avoid this problem in Visual SourceSafe 4.0 or 4.0a. - Use the Novell NetWare Client 32 for Windows 95.
- Enable project security if it is not already enabled. Disable the
destroy right for the Windows 95 users who use the Microsoft Client for
NetWare. This means that when they delete a file(s) and project(s) they
will not be able to destroy them. The administrator can then
periodically perform the purge option to remove the deleted files.
STATUS
Microsoft has confirmed this to be a bug in the Microsoft products listed
at the beginning of this article. This bug has been corrected in Visual
SourceSafe, version 5.0.
Modification Type: | Major | Last Reviewed: | 10/15/2002 |
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Keywords: | kbBug kbSSafe500fix KB164585 |
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