OL97: ErrMsg in Msspc.ecf and Msspc32.dll When Starting Outlook (164246)
The information in this article applies to:
This article was previously published under Q164246
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
When you start Microsoft Outlook 97, you may receive the following error:
The extension configuration file "C:\Program Files\Microsoft Office 97\
Office\Addins\Msspc.ecf..." could not be installed. There is an error
in the syntax or format of the file. Error in configuration file
"C:\Program Files\Microsoft Office 97\Office\Addins\Msspc.ecf...".
Unable to load "msspc32.dll". You may be out of memory, out of system
resources, or missing a .dll file.
CAUSE
An incorrect setup of the Schedule+ Support Files may cause this problem.
RESOLUTION
You can resolve this problem by using the Maintenance Mode of Setup to
remove and reinstall the Schedule+ Support Files.
To resolve this problem follow these steps:
- Exit all programs.
- Click the Start button, point to Settings and click
Control Panel.
- Double-click Add/Remove Programs icon.
- On the Install/Uninstall tab, click Microsoft Office 97
or Microsoft Outlook 97, depending on what you originally installed and
click Add/Remove to start the Maintenance Mode of Setup.
- When presented with the "Welcome to the Microsoft installation
maintenance program" dialog, click Add/Remove to view your
choices of components to remove.
- In the Options list, click to place a check by Microsoft Outlook and
then click Change Option.
- In the Options list, click to uncheck "Schedule+ Support Files" and
the click OK and Continue.
- After Setup has removed the Schedule+ Support Files, repeat the
above steps and click to install the Schedule+ Support Files.
- Restart your computer and start Outlook. You should no longer receive
the error message.
If the procedure above fails to correct the problem, do the following:
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall Windows 95. Microsoft cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be solved.
Use Registry Editor at your own risk.
For information about how to edit the registry, view the Changing Keys And
Values online Help topic in Registry Editor (Regedit.exe). Note that you
should make a backup copy of the registry files (System.dat and User.dat)
before you edit the registry.
- Copy the file MSSPC32.DLL, from the Office folder of your Office 97 CD,
into the Office folder on your computer. The default location for this
folder is c:\Program Files\Microsoft Office\Office.
- Change the Windows Registry to reflect the correct path to the
MSSPC32.DLL file as follows:
a. Click Start on the Windows Taskbar, then click Run.
b. Type REGEDIT in the Open window and click OK.
c. On the Registry menu, click Export Registry File.
d. Type REGISTRY in the File name window and click Save to backup your
registry to the desktop.
e. Navigate to the follow registry location:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\CLient\Extensions
f. Double-click the Schedule+ Value name and make sure its Value data
contains the correct path to the MSSPC32.DLL.
Following is an example of correct Value Data for the Schedule+ entry:
4.0;C:\Program Files\Microsoft Office\Office\msspc32.dll;2;01000000000001
REFERENCES
For more information about Maintenance Mode Setup, type add remove
components in the Office Assistant, click Search, and then click to view
"Install or remove individual components."
Modification Type: | Major | Last Reviewed: | 6/13/2001 |
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Keywords: | kbprb KB164246 |
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