OFF97: Errors Running Setup After "Run From CD" Installation (164163)
The information in this article applies to:
- Microsoft Office 97 for Windows
This article was previously published under Q164163 SYMPTOMS
When you run the Microsoft Office 97 Setup program in maintenance mode,
you may receive error messages similar to the following.
If You Click Reinstall
SelfReg
Failed to unregister .SRG file.
-and-
Setup could not create the folder 'D:\OFFICE\'.
-and-
There is not enough disk space to complete installation. You can
change your installation options, continue installation, or exit
Setup.
-and-
Setup tried to create an invalid path using 'D:\office\' and
'OFFICE\PSS8.HLP'.
NOTE: You receive over 100 error messages similar to the previous error
message.
-and-
Setup Parse Error in Initialize pass
Object ID 1081: RegFile Object: Failed to Register .SRG File
D:\Office\EXCEL8.SRG.
-and-
Setup could not open the file: 'D:\Office\EXCEL.EXE'.
-and-
Setup is not yet complete.
If you quit now, the product will not be installed properly.
Quit Setup?
If You Click Remove All
SelfReg
Failed to unregister .SRG file.
-and-
Setup Error in Initialize pass
Object ID 8623: RegMso Object: Failed to load Mso97.dll.
-and-
Microsoft Office 97 Setup was not completed successfully.
CAUSE
This problem occurs when the following conditions are true:
- You perform a Run From CD installation of Microsoft Office 97 on
your computer.
-and-
- You change the drive letter of the CD-ROM drive by installing a new
hard disk or other type of drive, by creating a new hard disk partition
(or partitions), or by manually changing the CD-ROM drive letter.
-and-
- You run the Setup program and click Reinstall or Remove All.
For example, if the CD-ROM drive is drive D when you perform a Run From CD
installation of Microsoft Office 97, and you then change the CD-ROM drive
to drive J, the problem occurs when you run Setup and click Reinstall or
Remove All.
RESOLUTION
To prevent this problem from occurring, do not change the drive letter of
the CD-ROM drive after you install Microsoft Office 97.
If the problem described in this article already occurred, use the
following appropriate method.
Method 1
If the problem occurs after you run Setup and click Reinstall, run
Microsoft Office 97 Setup again. The Setup program allows you to perform a
new installation of Microsoft Office 97. All settings that refer to the
earlier CD-ROM drive designation are overwritten by the new settings.
Method 2
If the problem occurs after you run Setup and click Remove All, (or if you
have not run Microsoft Office 97 Setup since you changed the CD-ROM drive)
use the following steps:
- On the Start menu, point to Find, and click Files Or Folders.
- In the Named box, type Off97pro.stf or Off97std.stf. Verify that the Look In box refers to drive C,
and that the Include Subfolders check box is selected. Then, click Find
Now.
- In the list of found files, right-click the .stf file. On the shortcut
menu, click Rename.
- Change the file name to Off97pro.yyy or Off97std.yyy, and then press ENTER.
- Close the Find dialog box.
- Run Microsoft Office 97 Setup and perform a new installation of
Microsoft Office 97.
STATUS
This behavior is by design of Microsoft Office 97.
Modification Type: | Major | Last Reviewed: | 11/22/2000 |
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Keywords: | kbsetup KB164163 |
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