OFF97: Errors Running Setup After "Run From CD" Installation (164163)



The information in this article applies to:

  • Microsoft Office 97 for Windows

This article was previously published under Q164163

SYMPTOMS

When you run the Microsoft Office 97 Setup program in maintenance mode, you may receive error messages similar to the following.

If You Click Reinstall

SelfReg
Failed to unregister .SRG file.
-and-
Setup could not create the folder 'D:\OFFICE\'.
-and-
There is not enough disk space to complete installation. You can change your installation options, continue installation, or exit Setup.
-and-
Setup tried to create an invalid path using 'D:\office\' and 'OFFICE\PSS8.HLP'.
NOTE: You receive over 100 error messages similar to the previous error message.

-and-
Setup Parse Error in Initialize pass
Object ID 1081: RegFile Object: Failed to Register .SRG File
D:\Office\EXCEL8.SRG.
-and-
Setup could not open the file: 'D:\Office\EXCEL.EXE'.
-and-
Setup is not yet complete.
If you quit now, the product will not be installed properly.
Quit Setup?

If You Click Remove All

SelfReg
Failed to unregister .SRG file.
-and-
Setup Error in Initialize pass
Object ID 8623: RegMso Object: Failed to load Mso97.dll.
-and-
Microsoft Office 97 Setup was not completed successfully.

CAUSE

This problem occurs when the following conditions are true:
  • You perform a Run From CD installation of Microsoft Office 97 on your computer.

    -and-

  • You change the drive letter of the CD-ROM drive by installing a new hard disk or other type of drive, by creating a new hard disk partition (or partitions), or by manually changing the CD-ROM drive letter.

    -and-

  • You run the Setup program and click Reinstall or Remove All.
For example, if the CD-ROM drive is drive D when you perform a Run From CD installation of Microsoft Office 97, and you then change the CD-ROM drive to drive J, the problem occurs when you run Setup and click Reinstall or Remove All.

RESOLUTION

To prevent this problem from occurring, do not change the drive letter of the CD-ROM drive after you install Microsoft Office 97.

If the problem described in this article already occurred, use the following appropriate method.

Method 1

If the problem occurs after you run Setup and click Reinstall, run Microsoft Office 97 Setup again. The Setup program allows you to perform a new installation of Microsoft Office 97. All settings that refer to the earlier CD-ROM drive designation are overwritten by the new settings.

Method 2

If the problem occurs after you run Setup and click Remove All, (or if you have not run Microsoft Office 97 Setup since you changed the CD-ROM drive) use the following steps:
  1. On the Start menu, point to Find, and click Files Or Folders.
  2. In the Named box, type Off97pro.stf or Off97std.stf. Verify that the Look In box refers to drive C, and that the Include Subfolders check box is selected. Then, click Find Now.
  3. In the list of found files, right-click the .stf file. On the shortcut menu, click Rename.
  4. Change the file name to Off97pro.yyy or Off97std.yyy, and then press ENTER.
  5. Close the Find dialog box.
  6. Run Microsoft Office 97 Setup and perform a new installation of Microsoft Office 97.

STATUS

This behavior is by design of Microsoft Office 97.

MORE INFORMATION

One way to prevent the CD-ROM drive from being changed is to manually set the drive letter to a letter that is ordered later in the alphabet, for example, R or S. This reduces the likelihood that the CD-ROM drive is automatically changed when you install a new hard disk or create a new disk partition.

For information about changing the drive letter of a CD-ROM drive, please see the following article in the Microsoft Knowledge Base:

121244 How to Change the Drive Letter of a CD-ROM Drive


When you perform a Run From CD installation of Microsoft Office 97, most of the files that are used by Microsoft Office 97 programs are stored on the Microsoft Office 97 compact disc. Because of this, there are a large number of registry keys that refer to the locations of files on the compact disc.

If you change the drive letter for your CD-ROM drive, these settings no longer refer to the correct locations for the required files. As a result, you cannot run any of the Microsoft Office 97 programs unless you first reinstall Microsoft Office 97. If you run Microsoft Office 97 Setup and click Reinstall or Remove All, you may receive the error messages described in this article.

If you changed your CD-ROM drive letter and you already attempted to reinstall Microsoft Office 97, run Microsoft Office 97 Setup again and perform a new installation.

Modification Type:MajorLast Reviewed:11/22/2000
Keywords:kbsetup KB164163