ACC97: Reinstalling "Run From CD" Removes Microsoft Access Components (164097)
The information in this article applies to:
This article was previously published under Q164097 Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
If you run the Setup program after you install Microsoft Access 97 with
the Run From CD-ROM option, and you click Reinstall in the Installation
Maintenance dialog box, Microsoft Access 97 no longer starts. In Microsoft
Windows 95 or later, and Windows NT version 4.0, there is no shortcut for
Microsoft Access 97 on the Programs menu; in Microsoft Windows NT version
3.51, only the Setup icon remains in the program group. If you try to run
Msaccess.exe directly from the CD-ROM, you receive the following error
message:
Microsoft Access can't find the Visual Basic for Applications
dynamic-link library (DLL) Vba332.
NOTE: This occurs with both Microsoft Access 97 and Microsoft Office 97
Professional Edition.
CAUSE
When you click Reinstall in the Installation Maintenance dialog box for a
Run From CD-ROM installation, Setup removes most of the Microsoft Access
97 files and registry entries that you need to run the program.
NOTE: This error may also occur if Microsoft Access 97 Setup does not
complete successfully.
RESOLUTION
Follow these steps to reinstall Microsoft Access 97 or Microsoft Office 97
Professional Edition:
- Start the Setup program, and click Remove All in the Installation
Maintenance dialog box.
- Start the Setup program again, and select the Run From CD-ROM
installation option.
NOTE: If you choose not to install Microsoft Office 97 Professional
Edition with the Run From CD option, and instead you select a Typical or
Custom installation, you may receive one of the following error messages
at the end of Setup:
Bdrintl.dll was unable to register itself in the system registry.
-or-
Vbe.dll was unable to register itself in the system registry.
When you click OK, you receive the error message:
Microsoft Office 97 Setup was not completed successfully.
These errors do not occur if you have Microsoft Access 97 as a stand-alone
product.
For more information about these error messages, please see the following
articles in the Microsoft Knowledge Base:
162295 Err Msg: "Bdrintl.dll Was Unable to Register Itself"
162627 Err Msg: "Vbe.dll Was Unable to Register Itself"
STATUS
Microsoft has confirmed this to be a problem in Microsoft Access 97.
REFERENCES
For more information about this issue, please see the following article in
the Microsoft Knowledge Base:
162295 Bdrintl.dll was Unable to Register Itself
Modification Type: | Major | Last Reviewed: | 10/3/2003 |
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Keywords: | kbbug kberrmsg kbsetup KB164097 |
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