SYMPTOMS
If you do both of the following on a Windows NT
Workstation-based computer that connects to a network printer share
- On the Start menu, point to
Settings, and then click Printers.
- Double-click the shared network printer icon.
you receive the following error message:
Access Denied: Unable to Connect
Therefore, the printer
queue that is displayed is empty, and users cannot control (for example, delete
or cancel) their own print jobs.
NOTE: You can still print from this computer even though you receive
this error message.
CAUSE
Systems Management Server Installer cannot handle multiple
REG_MULTI_SZ registry entries, but instead, only the first entry of such a
registry entry is used in the package.
The problem may occur after
you install a third-party product that added entries to the following registry
keys:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlset\Services\LanmanServer
\Parameters\NullSessionShares
HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlset\Services\LanmanServer
\Parameters\NullSessionPipes
In this case, when a Systems Management Server package was
created, Systems Management Server distributed only the first of the
REG_MULTI_SZ entries named above. All other entries (for example, spoolss)
were lost under the
NullSessionPipes key. This causes workstations to receive an "access denied" error
message when connecting to the printer share.
WORKAROUND
To work around this problem, use an external utility designed for
editing multi-string registry values. Execution of such utilities can be
accomplished within Systems Management Server Installer by using the Execute
Program script item.
STATUS
Microsoft has confirmed this to be a problem in Systems
Management Server Installer version 1.0, Windows NT Server versions 3.5, 3.51,
4.0, and Windows NT Workstation versions 3.5, 3.51, 4.0.
MORE INFORMATION
For more information on Systems Management Server Installer and
multiple REG_MULTI_SZ registry entries, see the following article in the
Microsoft Knowledge Base:
174328 SMSINST: Repackage Does Not Capture REG_MULTI_SZ Changes
For more information on services using the system account and
null sessions, see the following articles in the Microsoft Knowledge Base:
132679 Local System Account and Null Sessions in Windows NT
122702 Using the System Account as a Service in Windows NT 3.5
121281 LMHOSTS #Include Directives Requires Null Session Support