Money 5.0: Security Error Message Trying to Connect (162661)



The information in this article applies to:

  • Microsoft Money 97

This article was previously published under Q162661

SYMPTOMS

When trying to connect in Money 5.0 using Dial-Up Networking, you may receive the following error message:
There was an unexpected security error while trying to communicate with Online Services. Please try calling again. If this problem persists, please call Microsoft Technical Support.

CAUSE

This may be caused by an error in the installation of Windows 95 Dial-Up Networking or a problem with a file needed for a secure connection.

RESOLUTION

The resolution may involve several steps. Try each of these steps in sequence until you no longer receive the error.

NOTE: Refer to the More Information section below for detailed steps for the following procedures:
  1. Make sure that you restart Windows 95 after installing Money 5.0.
  2. Confirm the correct versions of required files are installed on your computer.
  3. Verify that TCP/IP is installed and bound to the Dial-Up Adapter.
  4. Delete the Dial-Up Networking connection for the services you are making.
  5. Remove Dial-Up Networking in Windows 95 and reinstall.
  6. Verify the Dial-Up Networking settings are correct for the connection being made.

MORE INFORMATION

Step through the following troubleshooting steps to resolve this error.

Restart Windows

When you install Money and say YES to set your system up for Online Services, Setup checks to see if Dial-Up Networking is installed on your computer. If Dial-Up Networking is not installed, Money Setup prompts you to insert your Windows 95 disks and install it. It is important that you install all files and then restart Windows.

Check Files

In Windows Explorer, verify the versions of the following files found in the Windows\System folder. Right-click on each and then click Properties. The version information is found on the Version tab.

NOTE: To make sure that you can see these files, On the View menu click Options. Click Show All Files and make sure that the "Hide MS-DOS File Extensions" box is clear.
    File Name       Size       Version
    ---------       ------     -------
    Wsock32.dll     66,560     4.00.950
    Wininet.dll    302,832     4.75.1135
    Schannel.dll   106,080     4.70.1135
    Rnaph.dll        9,728     4.00.951
				
Note: Regarding Schannel.dll, in addition to the above the words Domestic Use Only must appear in the Description.

If the version or sizes of your files are different, please see the following article in the Microsoft Knowledge Base for steps to replace the correct versions of these files.

For incorrect Wsock32.dll, please refer to the Resolution section of the following article:

158974 Money Err Msg: Unable to Register Schannel.dll

For incorrect versions of Wininet.dll, Schannel.dll, or Rnaph.dll, please refer to the Verify Dlls And Remove Money 97 And Reinstall section of the following article:

156886 Money 5.0: Problem Retrieving Online Setup Information

TCP/IP Bound to Dial-Up Adapter

Verify that TCP/IP is installed and bound to the Dial-Up Adapter. To check this in the Dial-Up Adapter Properties dialog box, do the following:
  1. Click the Start button, point to Settings and then click Control Panel.
  2. Double-click Network.
  3. Click Dial-Up Adapter, and then click Properties.
  4. Click the Bindings tab and make sure that the TCP/IP box is checked. If checked, go to the Delete the Dial-Up Networking Connection section below.
  5. If TCP/IP is not listed, click Cancel.
  6. Install TCP/IP.

    NOTE: You must have your Windows 95 CD-ROM or disks.
    1. Click Add.
    2. Click Protocol and click Add.
    3. In the Manufacturers list, select Microsoft. In the Network Protocols list, select TCP/IP and click OK.
    4. Insert your Windows 95 disks to copy the necessary files.
    5. Close the Network Properties dialog box.
    6. Restart Windows.
  7. Confirm that TCP/IP is now bound to the Dial-Up Adapter, following steps 1-4 above.
  8. Try your call again.

Delete the Dial-Up Networking Connection

Windows 95 creates Dial-Up Connections using the Dial-Up Networking Services. The slang term for this connection is connectoid. Money has a Dial-Up Connection called Money Online that is used to connect to the Branding Server to download information about your bank. If your financial institution or Online Bill Payment service provider uses Dial-Up Networking to make connections in Money, there will be a Dial-Up Connection in Dial-Up Networking for it.

Delete the Dial-Up Network Connection for the service that is generating the error and let Money build a new one by following these steps:
  1. Click the Start button, then point to Programs, then Accessories, and then click Dial-Up Networking.
  2. If the Welcome to Dial-Up Networking screen appears, click Cancel.
  3. If the error occurs during the Setup for Online Services, click Money Online to select it. If the error occurs during a call to CheckFree or to an OFC financial institution, click the appropriate connection to select it.
  4. Press the DELETE key and then click Yes to confirm you want to delete the connection.
  5. Try your call again.

Reinstall Dial-Up Networking

To remove Dial-Up Networking and reinstall, follow these steps:
  1. Click the Start button, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the Windows Setup tab and double-click Communications.
  4. Clear the Dial-Up Networking checkbox and click OK twice.
  5. Restart Windows.
  6. Repeat steps 1-3 above.
  7. click the Dial-Up Networking checkbox to place a check in it.
  8. Click OK twice. Insert your Windows disks if requested.
  9. Restart Windows and repeat the steps in the TCP/IP Bound to Dial-Up Adapter section above.
NOTE: The TCP/IP protocol may not be installed during the installation of Dial-Up Networking and may need to be installed separately.

Confirm Dial-Up Networking Settings

To verify the correct settings in Dial-Up Networking connection do the following:
  1. Click the Start button, then point to Programs, then Accessories, and then click Dial-Up Networking.
  2. Right-click the Dial-Up Connection and click Properties.
  3. Click Server Type and check the following:
    1. The Type of Dial-Up Server should be:

      PPP:Windows 95, Windows NT3.5, Internet

    2. Make sure that Enable software compression and TCP/IP are the only items checked.
    3. Click OK and close the Dial-Up Networking dialog box.
  4. Try your call again.
For additional information, please see the following article in the Microsoft Knowledge Base:

157435 How To Obtain Bank Contact Information From The Internet

STATUS

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:7/12/2001
Keywords:kberrmsg KB162661