ACC: Exporting to FoxPro 3.0 Does Not Create a .CDX File (162659)



The information in this article applies to:

  • Microsoft Access for Windows 95 7.0
  • Microsoft Access 97

This article was previously published under Q162659
Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

When you export a Microsoft Access table to a Microsoft FoxPro 3.0 file format, a FoxPro index file (*.cdx) is not created. However, a .cdx file is created when you export a Microsoft Access table that contains an index to a Microsoft FoxPro 2.0, 2.5, or 2.6 file format.

CAUSE

Microsoft Access 7.0 and 97 do not support creating indexes on Microsoft FoxPro 3.0 tables.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce Behavior


  1. Open the sample database Northwind.mdb.
  2. Select the Suppliers table in the Database window.
  3. On the File menu, click Save As/Export.
  4. In the Save As dialog box, click "To an External File or Database," and then click OK.
  5. In the "Save Table 'Suppliers' In" dialog box, select Microsoft FoxPro 3.0 (*.dbf) in the Save As type box, and then click Export.
  6. Start Windows Explorer or File Manager, and open the folder in which you saved the FoxPro file. Note that Microsoft Access created a Supplier.dbf file, but there is no corresponding Supplier.cdx file.

REFERENCES

For more information about exporting to Microsoft FoxPro file formats, search the Help Index for "FoxPro, exporting Access data," or ask the Microsoft Access 97 Office Assistant.

Modification Type:MajorLast Reviewed:10/20/2003
Keywords:kbinterop kbprb KB162659