Error 87 and Dr. Watson (162623)



The information in this article applies to:

  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0

This article was previously published under Q162623

SYMPTOMS

An application may abruptly stop running and one of the following Dr. Watson messages may appear:
Could not attach to the application.
Windows NT error code = 87
-or-
Windows NT Error Code 87
A log file is then created and when the user opens the log file, there is no special entry except:
The Error reported is

Could not Attach to the application
Windows NT Error Code 87

CAUSE

This error occurs when an application abnormally terminates itself or is unexpectedly terminated by another application, thus causing an access violation. Windows NT Error Code 87 occurs when Dr. Watson loads to log the error, but the process is shut down before Dr. Watson can access it to gather debug information.

Because Dr. Watson does not attach itself to the application, no debugging information is available in the log file.

This error is not the result of Windows NT closing down the application.

Modification Type:MajorLast Reviewed:8/9/2001
Keywords:kbinfo kbusage KB162623