SLI Libraries Set Wrong RU Size After Unbind(Hold) (162592)
The information in this article applies to:
- Microsoft SNA Server 2.11
- Microsoft SNA Server 2.11 SP1
- Microsoft SNA Server 3.0
This article was previously published under Q162592 SYMPTOMS
Some 32-bit SLI applications may fail when you try to transfer large
amounts of data. Investigation shows that the SNA RUI layer is returning an
error code of DATA_TRUNCATED when performing a RUI_READ of more than 256
bytes.
CAUSE
There is a problem the SLI library such that it is not picking up the RU
size correctly on successive BINDs. When the SLI library receives a BIND,
followed by UNBIND(HOLD) and then a new BIND, the SLI library posts an
RUI_READ of 256 bytes, even though 3840 byte RUs were negotiated in the
final BIND.
So, when an RU arrives on the session which is larger than 256 bytes, the
SLI_RECEIVE posted only receives 256 bytes and gets a DATA_TRUCATED error
from the underlying RUI libraries and the SLI application only gets the
first 256 bytes of the host application message.
Following is an illustration of the data flow involved:
SNA Server Host
---------- ----
<------------------- BIND ("NMP" session manager),
SLU receive size = "85"(256)
BIND +RSP --------------------------->
<logon>
<---------------------- UNBIND(Hold)
UNBIND +RSP ---------------------->
<------------------- BIND (Host SLI application),
SLU receive size = "F8" (3840)
BIND +RSP -------------------------->
<RUI_READ only reads 256 bytes >
RESOLUTION
Apply the update to SNA Server 2.11 Service Pack 1 and SNA Server 3.0 that
corrects this problem. The updated module is Winsli32.dll.
VTAM programmers will be able to work around this problem by configuring
their session manager (NMP) to send a BIND to SNA Server that specifies a
PLU send size of "F8" (this is set in Byte 11 of the BIND message).
NOTE: This is NOT the BTU size, but MAXDATA if configured in the LU
definition or RUSIZE if configured in the MODETAB for the LU-LU session (or
the NMP host session manager application).
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.
A supported fix is now available, but has not been fully regression-tested
and should be applied only to systems experiencing this specific problem.
Unless you are severely impacted by this specific problem, Microsoft
recommends that you wait for the next Service Pack that contains this fix.
Contact Microsoft Technical Support for more information.
Modification Type: | Major | Last Reviewed: | 11/19/2003 |
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Keywords: | kbnetwork KB162592 |
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