SMS: Job Status MIF Processing Slow on Large JobDetails Table (162558)
The information in this article applies to:
- Microsoft Systems Management Server 1.2
This article was previously published under Q162558 SYMPTOMS
After many Job Status MIFs have been processed and loaded in the Systems
Management Server database, the time taken by the Dataloader to process job
status MIFs may increase significantly. In some cases, the increase in
processing time between a JobDetails table with 100 records and a
JobDetails table with 230,000 records may be as much as a factor of 50.
CAUSE
The JobDetails table has an index on the MachineID column. However, in Job
Status MIF processing, this index is not used by the majority of queries
made by the Dataloader.
WORKAROUND
To work around this problem, obtain the hotfix mentioned below.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server
version 1.2.
A supported fix is now available, but is not fully regression-tested and
should be applied only to systems experiencing this specific problem.
Unless you are severely impacted by this specific problem, Microsoft
recommends that you wait for the next Service Pack that contains this fix.
Contact Microsoft Technical Support for more information.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
---|
Keywords: | kbbug kbDatabase kbDataLoader kbnetwork KB162558 |
---|
|