OFF97: Page Fault in MSO97 When Printing (162411)



The information in this article applies to:

  • Microsoft Office 97 for Windows, Service Release 1 (SR-1)
  • Microsoft Word 97 for Windows
  • Microsoft PowerPoint 97 for Windows
  • Microsoft Excel 97 for Windows

This article was previously published under Q162411

SYMPTOMS

When you click Print on the File menu in any of the programs listed at the beginning of this article, you may receive one of the following error messages.

If You Are Using Microsoft Word SR-1

You receive the following error message:
Word cannot change printers. No printers installed.

If You Are Using a Version of the Program Earlier Than SR-1

You receive the following error message
Invalid Page Fault in MSO97.dll
and the program stops responding (hangs), and the Print dialog box never appears.

If You Are Using Powerpoint

You receive the following error message:
PowerPoint found an error it cannot correct.

CAUSE

This problem may be related to a conflict with the IBM Client Access/400 software that is used to connect Intel-based workstation computers to IBM AS/400 computers.

Also note that other programs that modify the printers list may cause this problem.

RESOLUTION

To resolve this problem, contact IBM to determine if you have the latest available patch. The latest service pack for Client Access is available at the following Web address: The third-party contact information included in this article is provided to help you find the technical support you need. This contact information is subject to change without notice. Microsoft in no way guarantees the accuracy of this third-party contact information.

IBM has confirmed that this behavior is a problem with Client Access software and that there is a patch that corrects this behavior. The information below was extracted Sept 22, 1997, and may have changed.
   Windows 95   Latest          Date        Installed  Target date
   /NT Mod      Service Pack    PTF         File Date  for Next
   Level        PTF Number      Available              Service Pack

   V3R1M2       SF41904         08/01/97    02/05/97   09/30/97
   V3R1M1       SF42350         08/29/97    12/13/96   11/26/97
   V3R1M0       SF40785         05/30/97    08/12/97   Not planed
   V3R1M0       SF40785         05/30/97    08/12/96   Not in plan
				

To temporarily work around this problem, remove or deactivate the IBM client Access/400 software.

For additional information about how to contact IBM, please see the following articles in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

STATUS

This problem occurs when you use the Microsoft products listed at the beginning of this article and IBM Client Access/400 software. The SR-1 versions of these products correct the hanging problem. To completely correct this problem, you must obtain the patch described in the "Resolution" section of this article.

MORE INFORMATION

The third-party products discussed here are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:kb3rdparty kbbug kberrmsg kbfix KB162411