ACC95: Error Message: "Microsoft Access Can't Find the Wizard" with a Local Setup (162357)
The information in this article applies to:
- Microsoft Access for Windows 95 7.0
This article was previously published under Q162357 Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you try to use a Microsoft Access 7.0 wizard with a local setup of
Microsoft Access 7.0, you may receive one of the following error messages:
This feature isn't installed.
Microsoft Access Can't Find the Wizard or there is a syntax error in the
declaration section of the Visual Basic module.
For information about troubleshooting these error messages with a
Workstation setup of Microsoft Access 7.0, please see the following article
in the Microsoft Knowledge Base:
162358 ACC95: Err "Microsoft Access Can't Find the Wizard" (Wkstn
Setup)
For information about troubleshooting these error messages in Microsoft
Access 97, please see the following article in the Microsoft Knowledge
Base:
167591 ACC97: "Microsoft Access Can't Find the Wizard" Error
Message
CAUSE
Below are the possible causes for these errors:
- The wizard is not set up on your computer, or a wizard file is missing.
- You have read-only permissions for the wizard files.
- A type library file is missing or misregistered.
- A file needed to run the wizards is mismatched or corrupted.
- You have mismatched versions of some files that are shared in
common with other Microsoft programs.
RESOLUTION
Each of the possible causes has its own resolution. If you are unsure what
is causing the error, try each resolution in order and check to see if the
wizard is fixed after each one.
The Wizard Is Not Set Up on Your Computer, or a Wizard File Is Missing
If you selected a Compact installation when you ran Setup for Microsoft
Access 7.0, then the wizards were not set up on your computer. Or if you
selected a Custom installation, but you cleared the Wizards option, then
the wizards were not set up on your computer.
For more information about the components installed by the Microsoft Access
7.0 Setup program, please see the following article in the Microsoft
Knowledge Base:
136132 ACC95: Components Installed by Each Type of Setup
To resolve the above issue, do one of the following:
- Use the Regsvr32.exe file to re-register your .dll files.
To reregister your .dll files using Regsvr32.exe, do the following:
- Verify that the Regsvr32.exe file is in your Windows\System
folder.
- Click the Start button, and then click Run.
- In the Open box, type the following:
Regsvr32 c:\progra~1\common~1\micros~1\dao\dao3032.dll
NOTE: An alternative method of registering DLLs is to use Windows
Explorer to find the DLL; then, double-click it, in the Open With
Box select Regsvr32.exe, and click OK. This creates a permanent
association of all DLLs with Regsvr32.exe. You can easily register
other unregistered DLLs by double-clicking them.
For information about how to obtain this file, please see the
following article in the Microsoft Knowledge Base:
161983 ACC: Regsv32a.exe Available in Download Center
- Check for missing wizards by searching your hard drive for the file
Wzmain70.mda, which is installed by default in the \Msoffice\Access
folder. If the file is missing, you might not have installed the
Microsoft Access 7.0 wizards, or the wizard file might have been deleted
from your hard drive. Rerun the Setup program and install the Wizards
option:
- Close all applications, including the Microsoft Office toolbar.
- Start the Setup program.
In Microsoft Windows 95 or Windows NT 4.0:
- Click the Start button on the taskbar, point to Settings, and
then click Control Panel.
- In Control Panel, double-click Add/Remove Programs.
- In the Add/Remove Programs Properties dialog box, click
Microsoft Access 7.0 or Microsoft Office Professional, and then
click Add/Remove.
In Microsoft Windows NT 3.51:
- Open the program group for Microsoft Access or Microsoft Office.
- Double-click the Setup icon.
- Check to see if the wizards were installed.
In the Microsoft Access for Windows 95 Setup Dialog Box:
- Click Add/Remove.
- In the Microsoft Access for Windows 95 Maintenance dialog box,
look to see if the Wizards option is selected. If it is not
selected, click the Wizards option and then click Continue.
Follow instructions on your screen to complete the installation.
If the Wizards option is selected, click the Cancel button, and
then click Reinstall in the Microsoft Access for Windows 95
Setup dialog box.
In the Microsoft Office Professional 95 Setup Dialog Box:
- Click Add/Remove.
- Select Microsoft Access, and then click Change Option.
- Look to see if the Wizards option is selected. If it is not
selected, click the Wizards option and then click Continue.
Follow instructions on your screen to complete the installation.
If the Wizards option is selected, click the Cancel button
twice, and then click Reinstall in the Microsoft Office
Professional 95 Setup dialog box.
- When the Setup program is finished, start Microsoft Access and try
to run the wizard.
You Have Read-Only Permissions for the Wizard Files
If the wizard files are set to read-only by any combination of network
permissions, file permissions, or user permissions, then the wizards may
fail. Check your user permissions for the folder that contains the
Microsoft Access 7.0 program, and check that the read-only file attribute
is not set for any of the following files in that same folder:
Msau7032.dll
Wd95acc.tlb
Wzcnf70.mda
Wzdat70.mdt
Wzlib70.mda
Wzmain70.mda
Wztool70.mda
A Type Library File Is Missing or Misregistered
Search your hard drive for the file Dao2532.tlb. The file is set up by
default in the \Program Files\Common Files\Microsoft Shared\Dao folder (for
Microsoft Windows 95) or in the \Winnt\Msapps\Dao folder (for Microsoft
Windows NT version 3.51). In Microsoft Windows NT version 4.0 the file may
be in either folder, depending on how the operating system was installed.
If you find Dao2532.tlb on your computer, do one of the following:
- Run the Setup program with a command-line option that resets the Windows
Registry settings for Microsoft Access:
- Insert the Microsoft Access for Windows 95 Disk 1 or the Microsoft
Office Professional for Windows 95 CD-ROM in the appropriate drive.
- In Microsoft Windows 95 or Windows NT version 4.0, click the Start
button on the taskbar, and then click Run.
In Microsoft Windows NT 3.51, in Program Manager or File Manager,
click Run on the File menu. - Type a command to run the Setup program using the /y switch, for
example
<Drive>:\setup /y
where <Drive> is the drive letter for your diskette or CD-ROM. - In the Installation Maintenance dialog box, click Reinstall.
- When the Setup program is finished, start Microsoft Access and try
to run the wizard.
- Use the Regsvr32.exe file to re-register your .dll files.
To reregister your .dll files using Regsvr32.exe, do the following:
- Verify that the Regsvr32.exe file is in your Windows\System
folder.
- Click the Start button, and then click Run.
- In the Open box, type the following:
Regsvr32 c:\progra~1\common~1\micros~1\dao\dao3032.dll
For information about how to obtain this file, please see the following
article in the Microsoft Knowledge Base:
161983 ACC: Regsv32a.exe Available in Download Center
If you do not find Dao2532.tlb on your computer, rerun the Setup program
and reinstall Microsoft Access 7.0:
- Perform steps 1 and 2 in the section called "The Wizard Is Not Set Up on
Your Computer, or a Wizard File Is Missing."
- In the Installation Maintenance dialog box, click Reinstall.
- When the Setup program is finished, start Microsoft Access and try to
run the wizard.
A File Needed to Run the Wizards Is Mismatched or Corrupted
Once you determine that none of the previous steps resolve the error
message you receive when you try to run a wizard, you must remove and
reinstall Microsoft Access for Windows 95 or Microsoft Office Professional
for Windows 95.
The Setup program will not remove any Microsoft Office files that you
created from your hard drive. However, it is strongly recommended that you
back up any Microsoft Office files that are important to you before you
follow these steps.
- Perform steps 1 and 2 in the section called "The Wizard Is Not Set Up on
Your Computer, or a Wizard File Is Missing."
- In the Installation Maintenance dialog box, click Remove All. When
prompted, confirm that you want to remove the program.
- Delete the following files from the Msoffice\Access folder if they
exist.
NOTE: If you are using Windows Explorer, click Options on the View menu
and verify that the Show All Files option is selected. Without that
option, you may not see these files if they exist on your hard drive.
Msau7032.dll
Wd95acc.tlb
Wzcnf70.mda
Wzdat70.mdt
Wzlib70.mda
Wzmain70.mda
Wztool.mda
- Delete the following files from the Windows System folder if they exist.
NOTE: If you are using Windows Explorer, click Options on the View menu
and verify that the Show All Files option is selected. Without that
option, you may not see these files if they exist on your hard drive.
Msjetsql.tlb
Msjint32.dll
Msjt3032.dll
Msjter32.dll
Msrd2x32.dll
Mswng300.dll
Vaen232.dll
Vba232.dll
Vbajet32.dll
Vbar2232.dll
Ven2232.olb
- Delete the \Program Files\Common Files\Microsoft Shared\Dao folder (for
Microsoft Windows 95) or the \Winnt\Msapps\Dao folder (for Microsoft
Windows NT version 3.51 or 4.0).
- Reinstall Microsoft Access for Windows 95 or Microsoft Office
Professional for Windows 95. Do not choose a Compact setup.
- Start Microsoft Access and start the wizard.
Modification Type: | Minor | Last Reviewed: | 1/26/2005 |
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Keywords: | kberrmsg kbprb kbsetup KB162357 |
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