BUG: Visual FoxPro/Mac Setup Wizard Cannot Copy Source Files (162000)
The information in this article applies to:
- Microsoft Visual FoxPro for Macintosh 3.0b
This article was previously published under Q162000 SYMPTOMS
After you click the Finish button in the Visual FoxPro for Macintosh Setup
Wizard, a WAIT WINDOW appears with the message "Copying the source code
files . . ." followed by the following error message:
The Setup Wizard was unable to make a copy of your source files.
Setup terminated.
But the source files are indeed copied and a new folder is created with the
original name of the source folder plus the word "copy." But the Setup
Wizard is terminated.
CAUSE
This is known to happen if there are too many files in the source folder
and subfolders (called the Distribution Tree Folder in Step 1 of the Setup
Wizard). This problem is usually encountered when there is about 300 files
in the source folder or subfolders. The exact number has not been
determined. This problem has been seen when there were as few as 125 files
in the source folder. It appears that it is a combination of the number and
size of the files.
RESOLUTION
There can be a number of solutions to this problem, depending on the needs
of the application and the developer. Some possible solutions follow:
- Reduce the number of files that the application uses.
Sometimes developers distribute empty tables or report files as separate
files. These can be marked as included files in the project and built
into the executable file. If the table structure is needed, it can be
copied out of the executable with the COPY TO command. The same is true
with reports. The .frx file can be USEd (it is just a table) and the
COPY TO command used to copy it out to a report file that is external to
the executable so it can be modified. The implementation of this and the
interface in the application is left to the developer.
- Create two sets of installation disks. One set would have the executable
and other supporting files included by selecting the various check boxes
in Step #2 of the Setup Wizard. The other set of distribution disks
would contain the numerous supporting files the developer needs for the
application. They would be compressed by running the Setup Wizard but
not choosing a platform nor any of the other options in Step #2 of the
Setup Wizard. Both sets of distribution disks would be installed into
the same folder.
- Use one of the other commercially available setup programs. Two that
Microsoft is aware of are InstallerMaker from Aladdin Systems Inc. and
Installer VISE from Mind Vision Software. There should be others also.
The Web site addresses for each are below:
Aladdin Systems, Inc. and MindVision Software are vendors independent of
Microsoft; we make no warranty, implied or otherwise, regarding their
products' performance or reliability.
- Make sure that neither of the Visual FoxPro Support Library files are in
the Distribution Tree folder (the source folder). They are automatically
included when the platform is specified in step #2 of the Setup Wizard.
Including one or both of those files has been known to cause this
problem.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 2/4/2000 |
---|
Keywords: | kbbug KB162000 |
---|
|