Removing/Adding Wizards Fails to Create ISAM Registry Key (160954)
The information in this article applies to:
- Microsoft Access 97
- Microsoft Office 97 Developer Edition
This article was previously published under Q160954 Moderate: Requires basic macro, coding, and interoperability skills.
SYMPTOMS
When you run the Microsoft Access 97 or Microsoft Office 97 Professional
Edition Setup program to remove the Microsoft Access 97 Wizards, Setup
also removes the following options to import, export, or link to certain
file types:
Action File Types Removed
-----------------------------------------------------
Import Microsoft Excel (*.xls)
Text Files (*.txt;*.csv;*.tab;*.asc)
HTML Documents (*.html;*.htm)
Lotus 1-2-3 (*.wk*)
Link Microsoft Excel (*.xls)
Text Files (*.txt;*.csv;*.tab;*.asc)
HTML Documents (*.html;*.htm)
Save As/Export Microsoft Excel 5-7 (*.xls)
Microsoft Excel 4 (*.xls)
Microsoft Excel 3 (*.xls)
Microsoft Excel 97 (*.xls)
Text Files (*.txt;*.csv;*.tab;*.asc)
If you run Setup and reinstall the Microsoft Access 97 wizards, the
missing import, export, and link file types are not restored.
NOTE: The Lotus 1-2-3 indexed sequential access method (ISAM) driver is included in the Microsoft Office 97 ValuPack. For more information about
the drivers included in the ValuPack, please see the following article in
the Microsoft Knowledge Base:
159322 ACC97: Paradox, Lotus, & MS Exchange/Outlook ISAMs in ValuPack
CAUSE
When you remove the Microsoft Access 97 Wizards, some of the file types
that you can import, export, or link are removed also because they require
wizards. When you run Setup to reinstall the Microsoft Access 97 Wizards,
the Setup program restores the wizard files, but it does not re-create the
registry keys that allow you to import, export, or link to certain
file types.
RESOLUTION
There are two possible methods for resolving this problem:
- Rename the Setup.stf file and reinstall Microsoft Access
-or-
- Add the Wizards with Maintenance Mode Setup, and then run Setup again
using a command line switch of /y
The following two sections describe each of these methods in detail.
Method 1: Renaming the Setup.stf and Reinstalling
To resolve this error and restore the missing options, rename your
program's setup information file, and then reinstall:
- For Microsoft Office 97 Professional edition, rename the Off97Pro.stf
file, and then reinstall Microsoft Office 97 from the original media.
- For the Microsoft Access 97 stand-alone program, rename the Acc97.stf
file, and then reinstall Microsoft Access 97 from the original media.
The setup information files are located in the C:\Program Files\Microsoft
Office\Office\Setup folder by default.
If you installed the Lotus 1-2-3 ISAM driver, you must also rerun Setup
for the Data Access Pack, and then reinstall that driver.
Method 2: Maintenance Mode Setup and Setup /y
Add the wizards again by running the Setup program in Maintenance Mode.
Then, run the Setup program a second time using the command line switch of
"setup /y" to add the missing Registry key.
- Run setup from the CD that installed Microsoft Access. This should
start Maintenance Mode setup.
- In the first Office setup dialog box, Click Add/Remove.
- In the second Office setup dialog box, click Access in the list, and
then click the Change Options button.
- Click to select the Wizards and Advanced Wizards check boxes in the
third Office setup dialog box, and then click OK.
- Click Continue to add the wizards again, and then click the Restart
Windows option.
- Using the same CD that you used originally to install Microsoft
Access, run Setup again by following these steps:
- On the Windows Start menu, click Run.
- Enter the following command line (assuming the CD-ROM is d:\):
D:\ setup /y
and then click OK. - In the first Office setup dialog box, click Reinstall.
- Click to restart Windows at the end of the Microsoft Office
setup program.
If you installed the Lotus 1-2-3 ISAM driver, you must also rerun Setup
for the Data Access Pack, and then reinstall that driver.
NOTE: If these two methods do not resolve the issue, you may be experiencing a separate issue detailed in one of the following two articles:
For additional information, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
155666 ACC: Troubleshoot "Couldn't Find Installable ISAM" Error
171955 ACC97: Certain ISAM Drivers Not Appearing in Files Of Type Box
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 11/3/2003 |
---|
Keywords: | kbprb kbsetup KB160954 |
---|
|