Windows NT Error Message: Alternate Drivers Cannot Be Installed (160902)
The information in this article applies to:
- Microsoft Windows NT Server 3.1
- Microsoft Windows NT Workstation 3.1
- Microsoft Windows NT Advanced Server 3.1
- Microsoft Windows NT Workstation 3.5
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 3.5
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
This article was previously published under Q160902 SYMPTOMS
When you try to install alternate operating system printer drivers, such as
Windows NT 3.51 printer drivers on a Windows NT 4.0 Server computer, you
may get the following error message:
Alternate drivers cannot be installed an unexpected error occurred.
The error message may also occur when you attempt to install a third-party
Windows NT 3.51 PostScript driver for a Windows NT 4.0 printer control
language (PCL) printer (or vise versa) using the Have Disk option.
CAUSE
This error is usually caused when using an OEM printer driver disk whose
printer description field, found in the Windows NT 3.5x Printer.inf file,
does not match that of the Windows NT 4.0 %SystemRoot%\Inf\Ntprint.inf
file. This problem can also occur when you try to add an alternate driver
in Windows NT 4.0 for a printer that was not natively supported in Windows
NT 3.5x while using the Windows NT 3.5x compact disc as the installation
source path.
For example, Windows NT 4.0 Ntprint.inf has the following entry for the HP
Color LaserJet 5:
[HP]
"HP Color LaserJet 5" = Pcl5ems.dll.bidi
The Hewlett-Packard OEM Windows NT 3.51 driver disk contains a Printer.inf
file whose entry does not match the description in the Windows NT 4.0
Ntprint.inf file:
[Options]
"HP Color LaserJet 5/5M (HP)" = hpc2ui, hpc2lpd, hpc2drv
RESOLUTION
If you are installing a third-party printer driver as an alternate driver,
make sure that the non-native driver is the same type (PCL or PostScript)
as the Windows NT printer.
-or-
If the printer descriptions in the Printer.inf and Ntprint.inf files do not
match, use the following steps to resolve this problem:
- Copy the vendor-supplied installation files to a folder on your
hard disk drive, including the printer information file (Printer.inf).
If desired, make a backup copy of the Printer.inf file.
- In Notepad, open the Windows NT 4.0 Ntprint.inf file located in the
%SystemRoot%\Inf folder.
- Search for the description field for the printer in question and make a
note of it for step six.
- In Notepad, open the Printer.inf file from the vendor-supplied files on
the hard disk drive.
- Search for the description of the same printer in question.
- Change the description in the Printer.inf file to match the description
in the Ntprint.inf file as noted in step two.
- Close and save the changes in the Printer.inf file.
- Close the Ntprint.inf file (with no changes made).
- Click the Start button, point to Settings, and then click Printers.
Right-click the printer in question and click Properties, and then click
the Sharing tab.
- Select the alternate driver to install (that is, Windows NT 3.5 or
3.51 x86).
- When prompted with the message similar to the following:
Please insert the floppy disk labeled Windows NT 3.5 or
3.51 x86 into drive A:
Click OK and browse to the vendor-supplied folder on the hard disk
drive and select the modified Printer.inf file.
NOTE: You can also modify the Ntprint.inf file to match the description in
the vendor supplied Print.inf or Printer.inf file.
The remainder of the installation should no longer return errors, and the
alternate driver should be installed successfully.
MORE INFORMATION
This article does not apply to Windows 95. If you are installing a Windows
95 point and print driver on a computer running Windows NT for Windows 95
clients and you receive this error, please notify the vendor. To load
Windows 95 drivers on Windows NT 4.0, the vendor must follow the
specifications listed in the Windows 95 Resource Kit Appendixes C and D.
ISBN 1-55615-678-2. Please contact your vendor for an updated INF file.
The third-party products discussed here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.
Modification Type: | Major | Last Reviewed: | 5/13/2003 |
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Keywords: | kberrmsg kbnetwork kbprb kbprint KB160902 |
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