Internet Explorer 3.0 Causes Windows NT 4.0 to Blue Screen (160328)



The information in this article applies to:

  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q160328

SYMPTOMS

Microsoft Internet Explorer 3.0 causes Windows NT 4.0 to BLUE screen when you quit Internet Explorer 3.0 while the Word 95 drawing toolbar is open. At the time of this article blue screen information was not yet available.

CAUSE

Process objects were being destroyed on the destruction of the IE 3.0 process. IE 3.0 managed to have the last thread alive on the process which was being used for process object cleanup (which was a non-GUI thread). This thread handled menu cleanup but did not clean up GUI objects such as windows properly.

The code has been changed to clean up process objects on Thread cleanup for the last GUI thread in a process. This ensures that a GUI thread exists for window cleanup for the menu notification window.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0. This problem has been corrected in the latest U.S. service pack for Windows NT version 4.0. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbfix kbprb KB160328