ACC: Cannot Convert Database Without Default Printer (95/97) (160123)



The information in this article applies to:

  • Microsoft Access for Windows 95 7.0
  • Microsoft Access 97

This article was previously published under Q160123
Novice: Requires knowledge of the user interface on single-user computers.

SYMPTOMS

When you try to convert or open a Microsoft Access 1.x or 2.0 database, you may receive the following error message:

In Microsoft Access 97
----------------------
The process failed because there is no default printer.

This may be followed with the message:
Microsoft Access failed to create the Visual Basic module 'Form_<Form Name>'.

This is followed with the message:
The Save operation failed.

In Microsoft Access 7.0
-----------------------
You must set a default printer before you design, print or preview.

This error is followed by:
Microsoft Access failed to create or enable your code modules.

CAUSE

You do not have a default printer installed.

RESOLUTION

Use Control Panel to install a default printer. For information about how to do so, click Help on the Start menu, and then search on the phrase "default printer, setting," using the Windows Help Index.

MORE INFORMATION

In a Microsoft Access 7.0 or 97 database, you cannot create a report if you do not have a default printer installed. When you convert a database created with Microsoft Access 1.x or 2.0, a default printer is also required because Microsoft Access 7.0 and 97 will create a new database and import the objects as new objects.

REFERENCES

For more information about converting databases, search the Help Index for "converting databases," or ask the Microsoft Access 97 Office Assistant.

Modification Type:MajorLast Reviewed:10/20/2003
Keywords:kberrmsg kbprb KB160123