Invalid syntax error when you log on to Visual SourceSafe (159777)



The information in this article applies to:

  • Microsoft Visual SourceSafe for Windows 6.0
  • Microsoft Visual SourceSafe for Windows 5.0

This article was previously published under Q159777

SYMPTOMS

When you log on to Microsoft Visual SourceSafe, you may receive the following error message:
Invalid Syntax on line Line Number of the file Path of your Ss.ini File\SS.INI
If you try to log on to Visual SourceSafe by using the command line, you receive the following error message:
Invalid Syntax on line Line Number of the file Path of your Ss.ini File\SS.INI Too many SS.INI environment settings
In both error messages, Line Number is a placeholder for an integer.

CAUSE

In Visual SourceSafe 5.0, this problem occurs only if your Ss.ini file references settings for more than 10 computers.

In Visual SourceSafe 6.0, this problem occurs only if your Ss.ini file references settings for more than 24 computers.

RESOLUTION

Manually edit your Ss.ini file:
  • For Visual SourceSafe 5.0, reduce the number of references to computer names to 10 or less.
  • For Visual SourceSafe 6.0, reduce the number of references to computer names to 24 or less.

STATUS

This behavior is by design.

MORE INFORMATION

In Visual SourceSafe, user settings such as window size and window state, are all saved to the user's Ss.ini file. This behavior preserves the appearance of the Visual SourceSafe Explorer from one Visual SourceSafe session to another. The computer name identifies each entry.

If you log on through ComputerA, your Ss.ini file might contain entries that are similar to the following:

Maximized (ComputerA) = No
PrjWidth (ComputerA) = 260

If you log on through ComputerB later, your Ss.ini file might contain entries that are similar to the following:

Maximized (ComputerA) = No
PrjWidth (ComputerA) = 260
Maximized (ComputerB) = Yes
PrjWidth (ComputerB) = 300

You can log on to Visual SourceSafe through 10 different computers successfully (in this example, ComputerA through ComputerJ). However, if you try to log on through an eleventh computer (in this example, ComputerK), you receive the error message that appears in the "Symptoms" section.

Steps to reproduce the problem

  1. In a text editor such as Notepad, open your Ss.ini file. Your Ss.ini file is located in the \\Vss\Users\Your Visual SourceSafe User Name folder.
  2. Modify this file so that it contains references to 11 or more different computer names for Visual SourceSafe version 5.0 (or 25 or more different computer names for Visual SourceSafe version 6.0). You can do this by copying one line and then pasting it back into the file 10 times and then modifying each line to make it unique. The following are some example entries:

    (Beginning of the file)
    Hist_Rect (Computer1) = 188, 225, 721, 561, 1024, 768
    History_File_Columns (UI) = 75,85,135,100
    Maximized (Computer1) = No
    mssccprj = *.vbp, *.mak
    OutputHeight (Computer1) = 150
    Position_Toolbar (Computer1) = 222, 183, 676, 215, 1280, 1024
    PrjWidth (Computer1) = 260
    PrjWidth (Computer2) = 260
    PrjWidth (Computer3) = 260
    PrjWidth (Computer4) = 260
    PrjWidth (Computer5) = 260
    PrjWidth (Computer6) = 260
    PrjWidth (Computer7) = 260
    PrjWidth (Computer8) = 260
    PrjWidth (Computer9) = 260
    PrjWidth (Computer10) = 260
    PrjWidth (Computer11) = 260
    Toolbar (Computer2) = Yes

  3. Log on to Microsoft Visual SourceSafe

Modification Type:MajorLast Reviewed:12/12/2003
Keywords:kbprb kberrmsg kbSSafe600fix KB159777 kbAudDeveloper