PRB: Can Log on to a Locked Visual SourceSafe Database (159278)
The information in this article applies to:
- Microsoft Visual SourceSafe for Windows 5.0
- Microsoft Visual SourceSafe for Windows 6.0
- Microsoft Visual SourceSafe, 16-bit, for Windows 4.0a
- Microsoft Visual SourceSafe, 32-bit, for Windows 4.0a
This article was previously published under Q159278 SYMPTOMS
The Admin utility that ships with Visual SourceSafe version 5.0 allows the
Visual SourceSafe administrator to "lock" a database. In theory, when a
database is locked, no user can log on to the database. However, because
the database format between version 4.0a and 5.0 was not changed and the
database locking feature is new to version 5.0, users of Visual SourceSafe
Explorer 4.0a can log on to a locked 5.0 database.
CAUSE
Database locking is a new feature in version 5.0, and the Visual SourceSafe
Explorer version 4.0a does not check to see if the database is locked.
RESOLUTION
Upgrade all Visual SourceSafe installations to version 5.0 or above.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 5/4/2001 |
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Keywords: | kbprb KB159278 |
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