XL97: Drawing Objects and AutoShapes Printed Incorrectly (159227)
The information in this article applies to:
- Microsoft Excel 97 for Windows
- the operating system: Microsoft Windows 95
This article was previously published under Q159227 SYMPTOMS
When you print a worksheet or chart in Microsoft Excel 97, drawing
objects, AutoShapes, text boxes, and other objects may not be printed
correctly. Specifically, the following symptoms may occur:
- An object with a semi-transparent fill (text in cells behind the object
is visible) is printed with an opaque fill.
- An object with a semi-transparent fill is covered by a large black
rectangle or box.
- Objects, gridlines, and cell contents behind an object with an opaque
fill are visible in the printed output.
- Text in a text box with a colored or patterned background is not
printed.
- A pattern that you apply to an object is not printed correctly, or is
not printed at all.
- An irregularly shaped object, such as an oval or polygon, is printed
as a rectangle.
- An object may be printed with blurry or fuzzy edges.
These symptoms do not appear when you view the worksheet or chart in print
preview.
CAUSE
These problems may occur when all of the following conditions are true:
- You print to a printer that uses the universal printer driver,
Unidrv.dll. This includes most laser printers and inkjet printers.
NOTE: PostScript printers do not use Unidrv.dll, so they are not
affected.
-and- - You are using Microsoft Windows 95.
-and- - The printer driver is configured to print in vector mode.
This behavior occurs because Microsoft Excel 97 does not render these
types of objects correctly when the printer driver is configured to print
in vector mode.
NOTE: Because Windows NT supports printing only in raster mode, this
problem does not occur when you print from Microsoft Excel 97 under
Windows NT 3.51 or 4.0.
RESOLUTION
To resolve this problem, change the default print mode to raster mode. To
do this, follow these steps:
- Save your work and quit any running programs.
- On the Start menu, point to Settings, and click Printers.
- In the list of printers, right-click the printer driver for the
printer. On the shortcut menu, click Properties.
- Click the Graphics tab.
- Click Use Raster Graphics.
- Click OK.
If you want to print a single document in raster mode, follow these
steps:
- Switch to the document that you want to print.
- On the File menu, click Print. Then, click Properties.
- Click the Graphics tab.
- Select Use Raster Graphics.
- Click OK. Then, click OK again to print the document.
You may also be able to prevent this problem from occurring by installing
a newer version of the printer driver for your printer; however, note that
this may not work in all cases.
Modification Type: | Major | Last Reviewed: | 6/4/2001 |
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Keywords: | KB159227 |
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