XADM: Store Stops Responding with High CPU Usage (159176)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- the operating system: Microsoft Windows NT 3.51
- the operating system: Microsoft Windows NT 4.0
This article was previously published under Q159176 SYMPTOMS
The Microsoft Exchange Server Information Store service may appear to stop
responding with 90 to 100 percent CPU time. Any clients may also stop
responding; the cursor turns into the "wait" symbol (hourglass). When this
problem occurs, stopping and starting the Information Store reduces the
CPU
usage to normal levels and frees up the clients.
CAUSE
A Microsoft Exchange Server Information Store thread loops forever on a
Winsock recv() function. Winsock recv() is returning zero bytes received
because the remote computer has gracefully disconnected the connection.
The reason for the problem is that the Information Store thread is stuck
in
a remote procedure call (RPC). The RPC routine is continually calling the
Winsock recv() function because it is returning zero bytes read, which is
an error.
RESOLUTION
To resolve this problem, download and install the appropriate file:
Windows NT 3.51
This hotfix has been posted to the following Internet location:
Windows NT 4.0
This hotfix has been posted to the following Internet location:
STATUSWindows NT 4.0
Microsoft has confirmed this problem could result in some degree of
security vulnerability in Windows NT version 4.0.
A fully supported fix is now available, but it has not been fully
regression tested and should only be applied to systems determined to be at
risk of attack. Please evaluate your system's physical accessibility,
network and Internet connectivity, and other factors to determine the
degree of risk to your system. If your system is sufficiently at risk,
Microsoft recommends you apply this fix. Otherwise, wait for the next
Windows NT service pack, which will contain this fix. Please contact
Microsoft Technical Support for more information.
Windows NT 3.51
Microsoft has confirmed this problem could result in some degree of
security vulnerability in Windows NT version 3.51. A fully supported fix is
now available, but it has not been fully regression tested and should only
be applied to systems determined to be at risk of attack. Please evaluate
your system's physical accessibility, network and Internet connectivity,
and other factors to determine the degree of risk to your system. If your
system is sufficiently at risk, Microsoft recommends you apply this fix.
Otherwise, wait for the next Windows NT service pack, which will contain
this fix. Please contact Microsoft Technical Support for more information.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbbug kbfix KB159176 |
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