XADM: Forward Rule Causes MTA to NDR When Submitting Msg to IS (156796)
The information in this article applies to:
- Microsoft Exchange Server 4.0
This article was previously published under Q156796 SYMPTOMS
A Microsoft Exchange Inbox rule that forwards mail from a user in Site A to
a user in Site B may fail when the sites are not replicating but are
connected only via an address space. After carrying out the rule, the
Information Store will attempt to submit the message to the Message
Transfer Agent (MAT) for delivery, and then the MTA will produce a message
similar to the following in the application log:
An error occurred while transferring in message C=US;A= ;P=Organization;
L=DMSBLD-960824032321Z-45 because the directory name could not be
expanded to an O/R address. An X.400 API Association (XAPIA) unable-to-
transfer reason code and unrecognized-OR-name diagnostic code were
returned. [MTA SUBMIT 9 73] (14)
CAUSE
When a message is delivered by the MTA to the Information Store, it has the
MAPI property PR_ORIGINATOR_* stamped on it. The existing rules code does
not exclude the PR_ORIGINATOR_* information and this caused the originator
information to be included in the P1 envelope on an autoforwarded message.
Because the originator does not exist in the Directory where the message is
being forwarded, the MTA generates the NDR.
RESOLUTION
To resolve this problem, obtain the hotfix mentioned below. The rules code
was modified to exclude the PR_ORIGINATOR_* information on an
autoforwarding rule.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange version
4.0.
This problem was corrected in the latest Microsoft Exchange 4.0 U.S.
Service Pack. For information on obtaining the service pack, query on the
following word in the Microsoft Knowledge Base:
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
---|
Keywords: | kbbug kbfix kbusage KB156796 |
---|
|