Device Failure Message with Microchannel Network Adapter (156324)
The information in this article applies to:
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Workstation 4.0
This article was previously published under Q156324 SYMPTOMS
When you start Windows NT on a computer with a microchannel (MCA) network
adapter, you may receive the following error message:
At least one service or driver failed during system startup.
Use Event Viewer to examine the event log for details.
When you look at the event log, you see the following entry:
Event ID: 7000
Source: Service Control Manager
Description: A device connected to the system is not functioning.
After you log on to the computer, you may have no network access through
one or more of the microchannel network adapters.
CAUSE
The MCA Setup program and the adapter's Oemsetup.inf file identify the
slots on an MCA bus differently than the Windows NT hardware abstraction
layer (HAL). The Windows NT HAL identifies the slots beginning with 0 (for
example, physical slot 1 is SlotID 0), but the MCA setup program and the
Oemsetup.inf file start with 1.
RESOLUTION
This problem has been fixed in the file NDIS.SYS contained in Windows NT
4.0 Service Pack 2.0 and later service packs.
If after applying Service Pack-2 you still have the failure please refer
to Knowledge base article:
ARTICLE-ID: 167632
TITLE : MCA Network adapter fails after applying NT V4.0 SP2
STATUS
Microsoft has confirmed this to be a problem in Windows NT Version 4.0.
This problem has been corrected in the latest U.S. Service Pack for
Windows NT version 4.0. For information on obtaining the service pack,
query on the following word in the Microsoft Knowledge Base (without the
spaces):
Modification Type: | Major | Last Reviewed: | 8/8/2001 |
---|
Keywords: | kbHardware kbnetwork KB156324 |
---|
|