Premier Watch Locks Drive for Exclusive Use (155769)



The information in this article applies to:

  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51

This article was previously published under Q155769

SYMPTOMS

When you perform an operation that requires exclusive access to a volume that is on a system with Microsoft PremierWatch installed, the following error message appears:
The drive cannot be locked for exclusive use. Please check to see if some applications are currently accessing the drive. If so, close them and try again.

CAUSE

Microsoft's PremierWatch is an optional service to Microsoft Premier Support customers. It provides 24 x 7 x 365 remote monitoring of Windows NT servers. The objective of PremierWatch is to proactively identify and resolve server problems before they cause a service outage.

Monitoring can consist of Critical Alert Monitoring and/or Performance Monitoring. In either case, the hard disk drives are monitored for activity.

The volumes will not be available for any activity requiring exclusive use until the PremierWatch service is stopped.

RESOLUTION

To stop the PremierWatch service, use one of the two following methods:
  • Use the Services tool:
    1. In Control Panel, double-click Services.
    2. Select the PremWatch service.
    3. Click Stop.
    -or-

  • Run the following command at the command prompt:

    net stop PremWatch
You can now perform the operation that required exclusive access to the volume.

MORE INFORMATION

For additional information, please see the following article in the Microsoft Knowledge Base:

ARTICLE-ID: 136425
TITLE : Err Msg: The Drive Cannot be Locked for Exclusive Use


Modification Type:MajorLast Reviewed:3/29/2004
Keywords:KB155769