ACC95: Opening Replica DB Causes "File Already Exists" Error (155195)



The information in this article applies to:

  • Microsoft Access for Windows 95 7.0

This article was previously published under Q155195
Moderate: Requires basic macro, coding, and interoperability skills.

SYMPTOMS

When you open a replica copy of a database you receive the following error message:
File already exists

When you click the OK button, the database does not open.

CAUSE

One of the replicated form or report objects contains a missing or invalid Visual Basic for Applications module.

RESOLUTION

Take the following steps to fix the replicated database:
  1. Start Microsoft Access for Windows 95, but do not open a database.
  2. On the Tools menu, click Database Utilities, then click Compact Database. Compact your Design Master database to a new database name in the same folder.
  3. Rename your original Design Master database to a new name.
  4. Rename the newly compacted database to the original Design Master name.

    NOTE: The newly compacted database becomes your new Design Master database. When you are confident that your application is working smoothly again, you can delete the original Design Master database that you renamed in step 3, or save it as an incremental backup.
  5. Open the new Design Master database.
  6. Open any module in your database in Design view and change it in some way. For example, you can add a blank line to the Declarations section of a module.
  7. On the Run menu, click Compile All Modules.
  8. On the File menu, click Save All Modules.
  9. Close the module.
  10. On the Tools menu, point to Replication, then click Synchronize Now.
  11. Click Directly with Replica. In the list of replicas, click the name of the replica that causes the error message, then click OK.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access version 7.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

The form or report object causing the error may have been damaged as a result of problems associated with the Vba232.dll file that shipped with Microsoft Access for Windows 95. A newer version of this file is available.

For additional information, please see the following article in the Microsoft Knowledge Base:

147529 ACC95: Updated Vba232.dll Available in Download Center

REFERENCES

For more information about replicated databases, search on the phrase "database replication," using the Answer Wizard from the Microsoft Access 7.0 Help menu.

Modification Type:MajorLast Reviewed:7/2/2002
Keywords:kbbug kbenv kberrmsg KB155195