SYSDIFF /dump Err. Msg: The Data Is Invalid (154487)



The information in this article applies to:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q154487

SYMPTOMS

You may receive the following error message when you perform SYSDIFF /dump:
The data is invalid.

Clicking OK closes Sysdiff. Also, the output file that was created is incomplete and may contain an error message similar to:
Error 8 encountered; dump phase aborted.

CAUSE

This problem occurs when the difference file contains .INI entries that do not have equal signs in the appropriate places.

RESOLUTION

To resolve this problem, obtain the hotfix below, or wait for the next service pack. Please note that you must rebuild any packages that were built using the previous Sysdiff.exe.

This hotfix has been posted to the following Internet location:

ftp://ftp.microsoft.com/bussys/winnt/winnt-public/fixes/usa/NT40/ utilities/Sysdiff-fix

NOTE: This version of Sysdiff replaces the version that ships with Service Pack 3.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 4.0.



A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Modification Type:MajorLast Reviewed:8/8/2001
Keywords:kbbug kbfile kbsetup KB154487