OFF: Setup Does Not Default to Drive Specified in NI Wizard (153736)



The information in this article applies to:

  • Microsoft Office for Windows 95
  • Microsoft Excel for Windows 95
  • Microsoft PowerPoint for Windows 95
  • Microsoft Word for Windows 95
  • Microsoft Office 97 for Windows
  • Microsoft Word 97 for Windows
  • Microsoft Excel 97 for Windows
  • Microsoft PowerPoint 97 for Windows

This article was previously published under Q153736

SYMPTOMS

When you use the Network Installation Wizard to create a customized Setup Table file, and then run the Setup program to perform a client setup of Microsoft Office, Setup does not default to the correct disk drive.

CAUSE

This behavior occurs when the following conditions are met:

  • You perform an administrative setup of one of the versions of Microsoft Office listed above

    -and-
  • You start the Network Installation Wizard to create a custom Setup table file that Setup will use in a subsequent client setup.

    -and-
  • In the Network Installation Wizard, you specify a default destination folder (directory) for Office on a drive, partition, or volume other than your local drive(s) on your computer.

    -and-
  • You perform an interactive client setup of Office on a computer that uses the drive, partition, or volume that you specified as the default destination folder in the Network Installation Wizard.
This behavior does not occur when you perform a client setup of Office in batch (also called quiet) mode using the /q setup switch.

WORKAROUND

To work around this behavior, use the /q setup switch when you perform the client setup of Microsoft Office for Windows. To do this, type the following command at an MS-DOS prompt

<Folder Path>\Setup /q

where <Folder Path> refers to the folder on the server that contains the administrative installation of Microsoft Office.

NOTE: You may need to use the /t switch if the customized Setup Table file has a name other than Setup.stf.

STATUS

This behavior is by design of the Setup program.

MORE INFORMATION

This behavior occurs because the Setup program is designed to default to drive C when you perform an interactive client setup of Microsoft Office. However, the Setup program does not default to drive C when you perform a batch mode setup.

The Setup /t switch forces Setup to use a table file other than the default table file, while the Setup /q switch forces Setup to install predetermined application files with minimal user participation.

For additional information, please see the following articles in the Microsoft Knowledge Base:

137391 OFF95: Setup Switches for Office 7.0


Modification Type:MajorLast Reviewed:8/9/2006
Keywords:KB153736