Garbled Characters Appear in Windows NT Print Queue when Printing from Downlevel Client (152764)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q152764

SYMPTOMS

When a downlevel client (such as Windows 95) sends a print job to a Windows NT print server, you may not be able to read the document name on the server's print queue; however, the document prints correctly.

CAUSE

A downlevel client sends the document name formatted in its codepage and the protocol is not able to specify the codepage used. If the server has the same locale settings as the client, the document name is readable. However, there is a problem where the ANSI codepage is used to translate the document name instead of the OEM codepage.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Modification Type:MinorLast Reviewed:7/13/2004
Keywords:kbprint KB152764