ACC95: Database Password That Contains a Space Becomes Invalid After Compact (152760)



The information in this article applies to:

  • Microsoft Access for Windows 95 7.0

This article was previously published under Q152760

SYMPTOMS

When you set a database password that contains one or more spaces, the password becomes invalid after you compact the database.

CAUSE

When Microsoft Access 7.0 compacts your database, it removes all characters after and including the first space it encounters in the database password.

RESOLUTION

Choose a database password that does not contain spaces, or reset the database password you want every time you compact the database.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access 7.0. This problem no longer occurs in Microsoft Access 97.

MORE INFORMATION

Steps to Reproduce Behavior


  1. Create a new, blank Microsoft Access 7.0 database.
  2. Create a database password for the new database. To do so, follow these steps:

    1. Close the database.
    2. On the File menu, click Open Database.
    3. Click the Exclusive check box, and then open the database.
    4. On the Tools menu, point to Security, and then click Set Database Password.
    5. In the Password box, type this password: New Password. Be aware that passwords are case-sensitive.
    6. In the Verify box, confirm your password by typing the password again, and then click OK.
    The password is now set. The next time you or another user opens the database, a dialog box will be displayed that requests a password. (Remember that a password is case-sensitive; you must type it exactly as defined.)
  3. Close the database and reopen it. When prompted, type the database password: New Password. The database will open without any problems.
  4. Close the database again. On the Tools menu, point to Database Utilities, and then click Compact Database. Select the new database in the "Database To Compact From" dialog box, and type the password when prompted. Select the same database name in the "Compact Database Into" dialog box, and click Yes to "Replace existing file" prompt.
  5. Open the database and try to use the password: New Password. Note that you receive the following error message:
    "Not a valid password"

    Click OK and try again. This time use the password: New.
  6. Note that the database will open because Microsoft Access removed all characters in the password after the word "New" when the database was compacted.

REFERENCES

For more information about database passwords, search on the phrase "database password," and then view "Protect a database by adding a database password" using the Answer Wizard from the Microsoft Access for Windows 95 Help menu.

Modification Type:MinorLast Reviewed:1/26/2005
Keywords:kbbug kbfix kbusage KB152760