PRB: Demand-started Service Causes Computer to Hang (152661)



The information in this article applies to:

  • Microsoft Win32 Application Programming Interface (API), when used with:
    • the operating system: Microsoft Windows NT 3.51
    • the operating system: Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows XP

This article was previously published under Q152661

SYMPTOMS

A service is specified to start in the security context of a user. When the service is auto-started, it starts correctly. If it is demand-started (by the StartService API), the computer hangs. This state is demonstrated by the operating system becoming unresponsive. If you are starting the service from the service control panel applet, the hour-glass cursor fails to appear or, after a long delay, the "Attempting to Start Service" dialog box appears.

CAUSE

The problem is caused by an incorrectly written third-party network provider. The service control manager must check with each installed network provider in order to authenticate that the user name and password for the service are valid. If a network provider has trouble validating the user's credentials, the service control manager fails to start the service.

RESOLUTION

Remove the third-party network provider from the system. Please refer to your network provider documentation for more information on how to remove it from the system. Contact the network provider vendor for an update that resolves the problem.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:4/9/2004
Keywords:kb3rdparty kbKernBase kbprb kbService KB152661